You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@qpid.apache.org by "Keith Wall (JIRA)" <ji...@apache.org> on 2013/01/02 17:30:14 UTC

[jira] [Comment Edited] (QPID-3569) Refactor TransactionTimeout

    [ https://issues.apache.org/jira/browse/QPID-3569?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13541938#comment-13541938 ] 

Keith Wall edited comment on QPID-3569 at 1/2/13 4:28 PM:
----------------------------------------------------------

Proposed changes are as follows:

1) Moved the duplicated transactionUpdateTime member from AMQChannel/ServerSession to ServerTransaction.
  a) LocalTransaction now maintains advances transactionUpdateTime on each enqueue/dequeue operation
  b) Other non-transactional ServerTransaction impls return transactionUpdateTime of 0 (as they already do for transactionStartTime).
  c) Changed LocalTransaction so that transaction start time is recorded on first enqueue or dequeue operation (rather than only
     first enqueue)
2) Moved duplicated logic from AMQChannel/ServerSession#checkTransactionStatus to TransactionTimeoutHelper
3) Make TransactionTimeoutTests use a durable queue so it is actually testing with store transactions.

I plan to slim down TransactionTimeoutTests so we have fewer system tests, but this is not done yet.

Phil, could I ask you to review the attached patch and comment please?


 



                
      was (Author: k-wall):
    Proposed changes are as follows:

1) Moved the duplicated transactionUpdateTime member from AMQChannel/ServerSession to ServerTransaction.
  a) LocalTransaction now maintains advances transactionUpdateTime on each enqueue/dequeue operation
  b) Other non-transactional ServerTransaction impls return transactionUpdateTime of 0 (as they already do for transactionStartTime).
  c) Changed LocalTransaction so that transaction start time is recorded on first enqueue or dequeue operation (rather than only
     first enqueue)
2) Moved duplicated logic from AMQChannel/ServerSession#checkTransactionStatus to TransactionTimeoutHelper
3) Make TransactionTimeoutTests use a durable queue so it is actually testing with store transactions.

I plan to slim down TransactionTimeoutTests so we have fewer system tests, but this is not done yet.

Phil, could I ask you to review and comment please?


 



                  
> Refactor TransactionTimeout
> ---------------------------
>
>                 Key: QPID-3569
>                 URL: https://issues.apache.org/jira/browse/QPID-3569
>             Project: Qpid
>          Issue Type: Improvement
>          Components: Java Broker
>            Reporter: Keith Wall
>            Assignee: Philip Harvey
>         Attachments: 0001-QPID-3569-Refactor-TransactionTimeout.patch
>
>
> The Transaction Timeout feature of the Java Broker relies heavily on system tests.  It would be better if its implementation were refactored to allow more of its functionality to be tested by unit tests and a reduced number of system tests. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org