You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ignite.apache.org by "Anton Vinogradov (Jira)" <ji...@apache.org> on 2026/08/08 21:48:00 UTC
[jira] [Created] (IGNITE-28967) Rename GridDeploymentInfoBean to GridDeploymentInfoMessage
Anton Vinogradov created IGNITE-28967:
-----------------------------------------
Summary: Rename GridDeploymentInfoBean to GridDeploymentInfoMessage
Key: IGNITE-28967
URL: https://issues.apache.org/jira/browse/IGNITE-28967
Project: Ignite
Issue Type: Improvement
Reporter: Anton Vinogradov
{{GridDeploymentInfoBean}} is a {{Message}} that carries a deployment descriptor inside other messages, but its name says "Bean", which the internal code does not use anywhere else: the remaining {{*Bean}} classes are either Spring ({{IgniteSpringBean}}), public API ({{LifecycleBean}}), or JMX ({{*MBean}}, {{*MXBean}}).
Classes of the same nature are named without that suffix, for example {{BinaryMetadataVersionInfo}} and {{NodeEncryptionKeys}}, both {{Serializable}} plus {{Message}} parts of other messages.
The name cannot simply drop the suffix, because the class implements the {{GridDeploymentInfo}} interface, so rename it to {{GridDeploymentInfoMessage}}: it keeps the pair with the interface readable and matches {{ErrorMessage}} and {{QueryEntityMessage}}.
The change is mechanical: 53 usages in 15 files, no behaviour and no wire format involved.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)