You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-issues@hadoop.apache.org by "Colin Patrick McCabe (JIRA)" <ji...@apache.org> on 2014/07/12 02:52:05 UTC
[jira] [Updated] (HADOOP-10818) native client: refactor URI code to
be clearer
[ https://issues.apache.org/jira/browse/HADOOP-10818?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Colin Patrick McCabe updated HADOOP-10818:
------------------------------------------
Attachment: HADOOP-10818-pnative.001.patch
> native client: refactor URI code to be clearer
> ----------------------------------------------
>
> Key: HADOOP-10818
> URL: https://issues.apache.org/jira/browse/HADOOP-10818
> Project: Hadoop Common
> Issue Type: Sub-task
> Components: native
> Affects Versions: HADOOP-10388
> Reporter: Colin Patrick McCabe
> Assignee: Colin Patrick McCabe
> Attachments: HADOOP-10818-pnative.001.patch
>
>
> Refactor the {{common/uri.c}} code to be a bit clearer. We should just be able to refer to user_info, auth, port, path, etc. fields in the structure, rather than calling accessors. {{hdfsBuilder}} should just have a connection URI rather than separate fields for all these things.
--
This message was sent by Atlassian JIRA
(v6.2#6252)