You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@camel.apache.org by "Marco Zapletal (JIRA)" <ji...@apache.org> on 2011/09/20 15:00:09 UTC

[jira] [Created] (CAMEL-4468) Providing Interfaces for MBeans to be able to proxy them

Providing Interfaces for MBeans to be able to proxy them
--------------------------------------------------------

                 Key: CAMEL-4468
                 URL: https://issues.apache.org/jira/browse/CAMEL-4468
             Project: Camel
          Issue Type: Improvement
          Components: camel-core
    Affects Versions: 2.8.1
            Reporter: Marco Zapletal
            Priority: Trivial


This issue proposes to provide interfaces for the Camel JMX MBeans, which allows to (easily) proxy them on the client side (c.f. http://camel.465427.n5.nabble.com/Providing-Interfaces-for-MBeans-to-be-able-to-proxy-them-td4813271.html#a4813298) 

I would provide the patch for this but before, I ask the core developers for code conventions in terms of the interfaces: In which package should the interfaces be put and how should they be named?

Should they be put to the MBeans classes in org.apache.camel.management? But how to name them then, since for example IManagedRoute would break current camel naming conventions and identifiers such as ManagedRoute are already taken by the class implementations.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (CAMEL-4468) Providing Interfaces for MBeans to be able to proxy them

Posted by "Claus Ibsen (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/CAMEL-4468?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13116268#comment-13116268 ] 

Claus Ibsen commented on CAMEL-4468:
------------------------------------

I think ActiveMQ may use a naming of xxxMBean, so the interfaces could be named ManagedRouteMBean and so forth.

                
> Providing Interfaces for MBeans to be able to proxy them
> --------------------------------------------------------
>
>                 Key: CAMEL-4468
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4468
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-core
>    Affects Versions: 2.8.1
>            Reporter: Marco Zapletal
>            Priority: Trivial
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> This issue proposes to provide interfaces for the Camel JMX MBeans, which allows to (easily) proxy them on the client side (c.f. http://camel.465427.n5.nabble.com/Providing-Interfaces-for-MBeans-to-be-able-to-proxy-them-td4813271.html#a4813298) 
> I would provide the patch for this but before, I ask the core developers for code conventions in terms of the interfaces: In which package should the interfaces be put and how should they be named?
> Should they be put to the MBeans classes in org.apache.camel.management? But how to name them then, since for example IManagedRoute would break current camel naming conventions and identifiers such as ManagedRoute are already taken by the class implementations.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (CAMEL-4468) Providing Interfaces for MBeans to be able to proxy them

Posted by "Marco Zapletal (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/CAMEL-4468?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13125176#comment-13125176 ] 

Marco Zapletal commented on CAMEL-4468:
---------------------------------------

Ok - and what about the annotations? I would propose to move the to the interfaces like AMQ does it.
                
> Providing Interfaces for MBeans to be able to proxy them
> --------------------------------------------------------
>
>                 Key: CAMEL-4468
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4468
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-core
>    Affects Versions: 2.8.1
>            Reporter: Marco Zapletal
>            Priority: Trivial
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> This issue proposes to provide interfaces for the Camel JMX MBeans, which allows to (easily) proxy them on the client side (c.f. http://camel.465427.n5.nabble.com/Providing-Interfaces-for-MBeans-to-be-able-to-proxy-them-td4813271.html#a4813298) 
> I would provide the patch for this but before, I ask the core developers for code conventions in terms of the interfaces: In which package should the interfaces be put and how should they be named?
> Should they be put to the MBeans classes in org.apache.camel.management? But how to name them then, since for example IManagedRoute would break current camel naming conventions and identifiers such as ManagedRoute are already taken by the class implementations.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (CAMEL-4468) Providing Interfaces for MBeans to be able to proxy them

Posted by "Christian Schneider (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/CAMEL-4468?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13132705#comment-13132705 ] 

Christian Schneider commented on CAMEL-4468:
--------------------------------------------

Well the interface name depends a bit on the strategy we follow with JMX. We just discussed on the dev mailing list. We could either use standard MBeans or MXBeans or use the Annotations or eventually use both.

I still favour the MXBean aproach. In that case you name the interface like ManagedRouteMXBean. So JMX automatically recognizes this as a MXBean. The problem is that currently this turns off support for the management annotations. I could live with that but we have to decide that.

The interfaces should best go into an API package. org.apache.camel.api.management.mbean should be a good place. At least for the MBeans for the core.

                
> Providing Interfaces for MBeans to be able to proxy them
> --------------------------------------------------------
>
>                 Key: CAMEL-4468
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4468
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-core
>    Affects Versions: 2.8.1
>            Reporter: Marco Zapletal
>            Priority: Trivial
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> This issue proposes to provide interfaces for the Camel JMX MBeans, which allows to (easily) proxy them on the client side (c.f. http://camel.465427.n5.nabble.com/Providing-Interfaces-for-MBeans-to-be-able-to-proxy-them-td4813271.html#a4813298) 
> I would provide the patch for this but before, I ask the core developers for code conventions in terms of the interfaces: In which package should the interfaces be put and how should they be named?
> Should they be put to the MBeans classes in org.apache.camel.management? But how to name them then, since for example IManagedRoute would break current camel naming conventions and identifiers such as ManagedRoute are already taken by the class implementations.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira