You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@ignite.apache.org by Vyacheslav Daradur <da...@gmail.com> on 2017/01/25 15:24:10 UTC

Re: IGNITE-4374 - Ignite should validate JVM and OS configuration and output warning in log

GridPerformanceSuggestions isn't changed.

JVM checks are encapsulated in JvmConfigurationSuggestions
OS checks are encapsulated in OsConfigurationSuggestions

More information.
<https://issues.apache.org/jira/browse/IGNITE-4374?focusedCommentId=15832092&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-15832092>

Yakov, please, review it again.

2016-12-28 12:29 GMT+03:00 Vyacheslav Daradur <da...@gmail.com>:

> Yakov, I have looked at source codes and I agree with you.
>
> Let's rename GridPerformanceSuggestions to ConfigurationSuggestions
> and to add new checks to suggestOptimizations method in IgniteKernal or
> separate method.
>
> 2016-12-27 14:51 GMT+03:00 Vyacheslav Daradur <da...@gmail.com>:
>
>> I mean ConfigurationValidator as another class, not
>> GridPerformanceSuggestion.
>>
>> And invoke it from IgniteKernal.
>>
>> 2016-12-27 14:46 GMT+03:00 Vyacheslav Daradur <da...@gmail.com>:
>>
>>> >>
>>> 3. I think this should be a new section in performance suggestion output.
>>> And I think the GridPerformanceSuggestions should be used, but it should
>>> be
>>> probably renamed to reflect its new role and remove Grid prefix also. How
>>> about ConfigurationSuggestions?
>>> >>
>>> How about:
>>>
>>> public class ConfigurationValidator {
>>>
>>>       public static String getPerformanceSuggestions() {...}
>>>
>>>       public static List<String> getPerformanceSuggestions() {...}
>>>
>>> }
>>>
>>>
>>>
>>>
>>> 2016-12-27 14:12 GMT+03:00 Yakov Zhdanov <yz...@apache.org>:
>>>
>>>> Vyacheslav, my comments are below.
>>>>
>>>> >>
>>>> 1. It is necessary to check a flag MaxDirectMemorySize, but there is no
>>>> recommendation of it:
>>>> https://apacheignite.readme.io/docs/jvm-and-system-tuning
>>>>
>>>> 2. Whether it is necessary to output message in "Quiet mode"?
>>>>
>>>> 3. Where it is better to output information about checking? At the end
>>>> or
>>>> maybe before "Ignite node started OK"?
>>>> >>
>>>>
>>>> 1. Alex Goncharuk, can you please help here? How can we determine how
>>>> much
>>>> direct memory we need? Vyacheslav, you can skip this for the very first
>>>> version.
>>>>
>>>> 2. Yes
>>>>
>>>> 3. I think this should be a new section in performance suggestion
>>>> output.
>>>> And I think the GridPerformanceSuggestions should be used, but it
>>>> should be
>>>> probably renamed to reflect its new role and remove Grid prefix also.
>>>> How
>>>> about ConfigurationSuggestions?
>>>>
>>>> --Yakov
>>>>
>>>
>>>
>>
>

Re: IGNITE-4374 - Ignite should validate JVM and OS configuration and output warning in log

Posted by Denis Magda <dm...@apache.org>.
Thanks, reviewed.

—
Denis

> On Feb 7, 2017, at 3:58 AM, Vyacheslav Daradur <da...@gmail.com> wrote:
> 
> Hi, I changed the output.
> 
> Please, review it again)
> 
> If something is bad, I will quickly correct.
> 
> Thanks.
> 
> 2017-01-25 18:24 GMT+03:00 Vyacheslav Daradur <daradurvs@gmail.com <ma...@gmail.com>>:
> GridPerformanceSuggestions isn't changed.
> 
> JVM checks are encapsulated in JvmConfigurationSuggestions 
> OS checks are encapsulated in OsConfigurationSuggestions 
> 
> More information. <https://issues.apache.org/jira/browse/IGNITE-4374?focusedCommentId=15832092&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-15832092>
> 
> Yakov, please, review it again.
> 
> 2016-12-28 12:29 GMT+03:00 Vyacheslav Daradur <daradurvs@gmail.com <ma...@gmail.com>>:
> Yakov, I have looked at source codes and I agree with you.
> 
> Let's rename GridPerformanceSuggestions to ConfigurationSuggestions
> and to add new checks to suggestOptimizations method in IgniteKernal or separate method.
> 
> 2016-12-27 14:51 GMT+03:00 Vyacheslav Daradur <daradurvs@gmail.com <ma...@gmail.com>>:
> I mean ConfigurationValidator as another class, not GridPerformanceSuggestion.
> 
> And invoke it from IgniteKernal.
> 
> 2016-12-27 14:46 GMT+03:00 Vyacheslav Daradur <daradurvs@gmail.com <ma...@gmail.com>>:
> >>
> 3. I think this should be a new section in performance suggestion output.
> And I think the GridPerformanceSuggestions should be used, but it should be
> probably renamed to reflect its new role and remove Grid prefix also. How
> about ConfigurationSuggestions?
> >>
> How about:
> 
> public class ConfigurationValidator {
> 
>       public static String getPerformanceSuggestions() {...}
> 
>       public static List<String> getPerformanceSuggestions() {...}
> 
> }
> 
> 
> 
> 
> 2016-12-27 14:12 GMT+03:00 Yakov Zhdanov <yzhdanov@apache.org <ma...@apache.org>>:
> Vyacheslav, my comments are below.
> 
> >>
> 1. It is necessary to check a flag MaxDirectMemorySize, but there is no
> recommendation of it:
> https://apacheignite.readme.io/docs/jvm-and-system-tuning <https://apacheignite.readme.io/docs/jvm-and-system-tuning>
> 
> 2. Whether it is necessary to output message in "Quiet mode"?
> 
> 3. Where it is better to output information about checking? At the end or
> maybe before "Ignite node started OK"?
> >>
> 
> 1. Alex Goncharuk, can you please help here? How can we determine how much
> direct memory we need? Vyacheslav, you can skip this for the very first
> version.
> 
> 2. Yes
> 
> 3. I think this should be a new section in performance suggestion output.
> And I think the GridPerformanceSuggestions should be used, but it should be
> probably renamed to reflect its new role and remove Grid prefix also. How
> about ConfigurationSuggestions?
> 
> --Yakov
> 
> 
> 
> 
> 


Re: IGNITE-4374 - Ignite should validate JVM and OS configuration and output warning in log

Posted by Vyacheslav Daradur <da...@gmail.com>.
Hi, I changed the output.

Please, review it again)

If something is bad, I will quickly correct.

Thanks.

2017-01-25 18:24 GMT+03:00 Vyacheslav Daradur <da...@gmail.com>:

> GridPerformanceSuggestions isn't changed.
>
> JVM checks are encapsulated in JvmConfigurationSuggestions
> OS checks are encapsulated in OsConfigurationSuggestions
>
> More information.
> <https://issues.apache.org/jira/browse/IGNITE-4374?focusedCommentId=15832092&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-15832092>
>
> Yakov, please, review it again.
>
> 2016-12-28 12:29 GMT+03:00 Vyacheslav Daradur <da...@gmail.com>:
>
>> Yakov, I have looked at source codes and I agree with you.
>>
>> Let's rename GridPerformanceSuggestions to ConfigurationSuggestions
>> and to add new checks to suggestOptimizations method in IgniteKernal or
>> separate method.
>>
>> 2016-12-27 14:51 GMT+03:00 Vyacheslav Daradur <da...@gmail.com>:
>>
>>> I mean ConfigurationValidator as another class, not
>>> GridPerformanceSuggestion.
>>>
>>> And invoke it from IgniteKernal.
>>>
>>> 2016-12-27 14:46 GMT+03:00 Vyacheslav Daradur <da...@gmail.com>:
>>>
>>>> >>
>>>> 3. I think this should be a new section in performance suggestion
>>>> output.
>>>> And I think the GridPerformanceSuggestions should be used, but it
>>>> should be
>>>> probably renamed to reflect its new role and remove Grid prefix also.
>>>> How
>>>> about ConfigurationSuggestions?
>>>> >>
>>>> How about:
>>>>
>>>> public class ConfigurationValidator {
>>>>
>>>>       public static String getPerformanceSuggestions() {...}
>>>>
>>>>       public static List<String> getPerformanceSuggestions() {...}
>>>>
>>>> }
>>>>
>>>>
>>>>
>>>>
>>>> 2016-12-27 14:12 GMT+03:00 Yakov Zhdanov <yz...@apache.org>:
>>>>
>>>>> Vyacheslav, my comments are below.
>>>>>
>>>>> >>
>>>>> 1. It is necessary to check a flag MaxDirectMemorySize, but there is no
>>>>> recommendation of it:
>>>>> https://apacheignite.readme.io/docs/jvm-and-system-tuning
>>>>>
>>>>> 2. Whether it is necessary to output message in "Quiet mode"?
>>>>>
>>>>> 3. Where it is better to output information about checking? At the end
>>>>> or
>>>>> maybe before "Ignite node started OK"?
>>>>> >>
>>>>>
>>>>> 1. Alex Goncharuk, can you please help here? How can we determine how
>>>>> much
>>>>> direct memory we need? Vyacheslav, you can skip this for the very first
>>>>> version.
>>>>>
>>>>> 2. Yes
>>>>>
>>>>> 3. I think this should be a new section in performance suggestion
>>>>> output.
>>>>> And I think the GridPerformanceSuggestions should be used, but it
>>>>> should be
>>>>> probably renamed to reflect its new role and remove Grid prefix also.
>>>>> How
>>>>> about ConfigurationSuggestions?
>>>>>
>>>>> --Yakov
>>>>>
>>>>
>>>>
>>>
>>
>