You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@geode.apache.org by "Dave Barnes (Jira)" <ji...@apache.org> on 2021/05/21 19:15:00 UTC

[jira] [Commented] (GEODE-9042) Geode User Guide: update dockerfile to use newer ruby & gems

    [ https://issues.apache.org/jira/browse/GEODE-9042?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17349448#comment-17349448 ] 

Dave Barnes commented on GEODE-9042:
------------------------------------

[~alberto.bustamante.reyes] 

We've seen some progress that may help you to get un-stuck on this issue:
 * Bookbinder 1.10.16, which is updated to correct the mimemagic dependency, has been added to rubygems.
 * The geode-book/Gemfile can now explicitly require bookbindery 10.1.16.
 * The Dockerfile needs to be updated to use Ruby 2.5.3 or later, and it needs an instruction to update nodejs.

Hope this helps.

> Geode User Guide: update dockerfile to use newer ruby & gems
> ------------------------------------------------------------
>
>                 Key: GEODE-9042
>                 URL: https://issues.apache.org/jira/browse/GEODE-9042
>             Project: Geode
>          Issue Type: Improvement
>          Components: docs, tools
>    Affects Versions: 1.13.1
>            Reporter: Dave Barnes
>            Assignee: Alberto Bustamante Reyes
>            Priority: Major
>
> The scripts that build the user guide are pinned at Ruby 2.3.0 and Bookbinder 1.10.14.
> These need to be updated to Ruby 2.5.3 (or later) and Bookbinder 1.10.15 in order to support current deployment infrastructure.
> Path to the Bookbinder gem: http://docs-wiki.cfapps.io/wiki/bookbinder/installing-bookbinder.html#v10



--
This message was sent by Atlassian Jira
(v8.3.4#803005)