You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@flink.apache.org by "Stefan Bunk (JIRA)" <ji...@apache.org> on 2015/04/14 20:04:12 UTC
[jira] [Created] (FLINK-1890) Add withReadFields or sth. similar to
Scala API
Stefan Bunk created FLINK-1890:
----------------------------------
Summary: Add withReadFields or sth. similar to Scala API
Key: FLINK-1890
URL: https://issues.apache.org/jira/browse/FLINK-1890
Project: Flink
Issue Type: Wish
Components: Java API, Scala API
Reporter: Stefan Bunk
Priority: Minor
In the Scala API, you have the option to declare forwarded fields via the
{{withForwardedFields}} method.
It would be nice to have sth. similar for read fields, as otherwise one needs to create a class, which I personally try to avoid for readability.
Maybe grouping all annotations in one function and have a first parameter indicating the type of annotation is also an option, if you plan on adding more annotations and want to keep the interface smaller.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)