You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hive.apache.org by "Namit Jain (JIRA)" <ji...@apache.org> on 2009/08/12 16:13:14 UTC

[jira] Created: (HIVE-751) followup on 743

followup on 743
---------------

                 Key: HIVE-751
                 URL: https://issues.apache.org/jira/browse/HIVE-751
             Project: Hadoop Hive
          Issue Type: Bug
          Components: Query Processor
            Reporter: Namit Jain


@hive.743.2.patch:
Hive.g: Can we use "rowFormat", "rowFormatDelimited", "rowFormatSerDe" instead of "serde", "serdePropertiesFormat", and "serdeFormat"? I think that will be much more intuitive. We can also replace "tableRowFormat" with "rowFormat".

SemanticAnalyzer.genScriptPlan looks a bit ugly - can we add one level of nesting for inSerDe and outSerDe in Hive.g, and use a single loop over the children in genScriptPlan to get all corresponding children?
We can also add a "null" placeholder in case inSerDe / outSerDe is missing, so we don't need to calculate the child positions.

Otherwise it looks good.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (HIVE-751) Rename serde/serdeFormat etc in Hive.g for readability

Posted by "Namit Jain (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HIVE-751?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Namit Jain resolved HIVE-751.
-----------------------------

      Resolution: Fixed
    Hadoop Flags: [Reviewed]

fixed as part of 785

> Rename serde/serdeFormat etc in Hive.g for readability
> ------------------------------------------------------
>
>                 Key: HIVE-751
>                 URL: https://issues.apache.org/jira/browse/HIVE-751
>             Project: Hadoop Hive
>          Issue Type: Bug
>          Components: Query Processor
>            Reporter: Namit Jain
>            Assignee: Namit Jain
>
> @hive.743.2.patch:
> Hive.g: Can we use "rowFormat", "rowFormatDelimited", "rowFormatSerDe" instead of "serde", "serdePropertiesFormat", and "serdeFormat"? I think that will be much more intuitive. We can also replace "tableRowFormat" with "rowFormat".
> SemanticAnalyzer.genScriptPlan looks a bit ugly - can we add one level of nesting for inSerDe and outSerDe in Hive.g, and use a single loop over the children in genScriptPlan to get all corresponding children?
> We can also add a "null" placeholder in case inSerDe / outSerDe is missing, so we don't need to calculate the child positions.
> Otherwise it looks good.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HIVE-751) followup on 743

Posted by "Zheng Shao (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HIVE-751?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Zheng Shao updated HIVE-751:
----------------------------

    Assignee: Namit Jain

I believe some of the items are fixed by HIVE-708. The Hive.g rename is not done yet.


> followup on 743
> ---------------
>
>                 Key: HIVE-751
>                 URL: https://issues.apache.org/jira/browse/HIVE-751
>             Project: Hadoop Hive
>          Issue Type: Bug
>          Components: Query Processor
>            Reporter: Namit Jain
>            Assignee: Namit Jain
>
> @hive.743.2.patch:
> Hive.g: Can we use "rowFormat", "rowFormatDelimited", "rowFormatSerDe" instead of "serde", "serdePropertiesFormat", and "serdeFormat"? I think that will be much more intuitive. We can also replace "tableRowFormat" with "rowFormat".
> SemanticAnalyzer.genScriptPlan looks a bit ugly - can we add one level of nesting for inSerDe and outSerDe in Hive.g, and use a single loop over the children in genScriptPlan to get all corresponding children?
> We can also add a "null" placeholder in case inSerDe / outSerDe is missing, so we don't need to calculate the child positions.
> Otherwise it looks good.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HIVE-751) Rename serde/serdeFormat etc in Hive.g for readability

Posted by "Zheng Shao (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HIVE-751?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Zheng Shao updated HIVE-751:
----------------------------

    Summary: Rename serde/serdeFormat etc in Hive.g for readability  (was: followup on 743)

> Rename serde/serdeFormat etc in Hive.g for readability
> ------------------------------------------------------
>
>                 Key: HIVE-751
>                 URL: https://issues.apache.org/jira/browse/HIVE-751
>             Project: Hadoop Hive
>          Issue Type: Bug
>          Components: Query Processor
>            Reporter: Namit Jain
>            Assignee: Namit Jain
>
> @hive.743.2.patch:
> Hive.g: Can we use "rowFormat", "rowFormatDelimited", "rowFormatSerDe" instead of "serde", "serdePropertiesFormat", and "serdeFormat"? I think that will be much more intuitive. We can also replace "tableRowFormat" with "rowFormat".
> SemanticAnalyzer.genScriptPlan looks a bit ugly - can we add one level of nesting for inSerDe and outSerDe in Hive.g, and use a single loop over the children in genScriptPlan to get all corresponding children?
> We can also add a "null" placeholder in case inSerDe / outSerDe is missing, so we don't need to calculate the child positions.
> Otherwise it looks good.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.