You are viewing a plain text version of this content. The canonical link for it is here.
Posted to httpclient-users@hc.apache.org by Oleg Kalnichevski <ol...@apache.org> on 2025/10/13 10:21:14 UTC
[ANNOUNCEMENT] HttpComponents Core 5.4-alpha1 released
The Apache HttpComponents project is pleased to announce 5.4-alpha1
release of HttpComponents Core.
This is the first ALPHA release in the 5.4 release series that improves
HTTP/2 protocol support by ensuring conformance to the latest HTTP
specification (RFC 9113) and adds support for Unix domain sockets.
This release also includes all the fixes from the stable 5.3 branch.
Notable changes and features included in the 5.4 series:
* Experimental OFFLOCK (lock-free) connection pool.
* Conformance to RFC 9218 (Extensible Prioritization Scheme for HTTP).
* Improved conformance to RFC 9113 (Hypertext Transfer Protocol Version
2).
* Five-second TCP keep-alive enabled by default.
* Unix domain socket support by the classic and async transports.
* Redesign of classic over async API bridge.
* Improved URI encoding per RFC 3986.
* QUERY method support.
Download - <http://hc.apache.org/downloads.cgi>
Release notes -
<http://www.apache.org/dist/httpcomponents/httpcore/RELEASE_NOTES-5.4.x.txt
HttpComponents site - <http://hc.apache.org/>
About HttpComponents Core
HttpCore is a set of HTTP/1.1 and HTTP/2 transport components that can
be used to build custom client and server side HTTP services with a
minimal footprint.
---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-users-unsubscribe@hc.apache.org
For additional commands, e-mail: httpclient-users-help@hc.apache.org