You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@directory.apache.org by bu...@apache.org on 2016/03/07 12:29:48 UTC

svn commit: r982068 - in /websites/staging/directory/trunk/content: ./ apacheds/advanced-ug/7-embedding-apacheds.html apacheds/advanced-ug/8-operational-attributes.html apacheds/advanced-user-guide.html

Author: buildbot
Date: Mon Mar  7 11:29:48 2016
New Revision: 982068

Log:
Staging update by buildbot for directory

Added:
    websites/staging/directory/trunk/content/apacheds/advanced-ug/8-operational-attributes.html
Modified:
    websites/staging/directory/trunk/content/   (props changed)
    websites/staging/directory/trunk/content/apacheds/advanced-ug/7-embedding-apacheds.html
    websites/staging/directory/trunk/content/apacheds/advanced-user-guide.html

Propchange: websites/staging/directory/trunk/content/
------------------------------------------------------------------------------
--- cms:source-revision (original)
+++ cms:source-revision Mon Mar  7 11:29:48 2016
@@ -1 +1 @@
-1731213
+1733901

Modified: websites/staging/directory/trunk/content/apacheds/advanced-ug/7-embedding-apacheds.html
==============================================================================
--- websites/staging/directory/trunk/content/apacheds/advanced-ug/7-embedding-apacheds.html (original)
+++ websites/staging/directory/trunk/content/apacheds/advanced-ug/7-embedding-apacheds.html Mon Mar  7 11:29:48 2016
@@ -162,8 +162,8 @@
         </div>
         <div class="nav_next">
         
-			&nbsp;
-        
+            <a href="8-operational-attribures.html">8 - Operational Attributes</a>
+		
         </div>
         <div class="clearfix"></div>
     </div>
@@ -197,8 +197,8 @@ h2:hover > .headerlink, h3:hover > .head
         </div>
         <div class="nav_next">
         
-			&nbsp;
-        
+            <a href="8-operational-attribures.html">8 - Operational Attributes</a>
+		
         </div>
         <div class="clearfix"></div>
     </div>

Added: websites/staging/directory/trunk/content/apacheds/advanced-ug/8-operational-attributes.html
==============================================================================
--- websites/staging/directory/trunk/content/apacheds/advanced-ug/8-operational-attributes.html (added)
+++ websites/staging/directory/trunk/content/apacheds/advanced-ug/8-operational-attributes.html Mon Mar  7 11:29:48 2016
@@ -0,0 +1,316 @@
+<!DOCTYPE html>
+<!--
+    Licensed to the Apache Software Foundation (ASF) under one or more
+    contributor license agreements.  See the NOTICE file distributed with
+    this work for additional information regarding copyright ownership.
+    The ASF licenses this file to You under the Apache License, Version 2.0
+    (the "License"); you may not use this file except in compliance with
+    the License.  You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+    Unless required by applicable law or agreed to in writing, software
+    distributed under the License is distributed on an "AS IS" BASIS,
+    WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+    See the License for the specific language governing permissions and
+    limitations under the License.
+-->
+<html>
+	<head>
+		<title>8 - Operational Attributes &mdash; Apache Directory</title>
+		
+        <link href="./../../css/common.css" rel="stylesheet" type="text/css">
+    	<link href="./../../css/green.css" rel="stylesheet" type="text/css">
+    
+        
+        <link rel="shortcut icon" href="./../../images/server-icon_16x16.png">
+    
+        <!-- Google Analytics -->
+        <script src="http://www.google-analytics.com/urchin.js" type="text/javascript"></script>
+        <script type="text/javascript">
+            _uacct = "UA-1358462-1";
+            urchinTracker();
+        </script>
+	</head>
+	<body>
+	    <div id="container">
+            <div id="header">
+                <div id="subProjectsNavBar">
+                    <a href="./../../">
+                        
+                        Main
+                        
+                    </a>
+                    &nbsp;|&nbsp;
+                    <a href="./../../apacheds">
+                        
+                        <STRONG>ApacheDS</STRONG>
+                        
+                    </a>
+                    &nbsp;|&nbsp;
+                    <a href="./../../studio">
+                        
+                        Studio
+                        
+                    </a>
+                    &nbsp;|&nbsp;
+                    <a href="./../../api">
+                        
+                        LDAP API
+                        
+                    </a>
+                    &nbsp;|&nbsp;
+                    <a href="./../../mavibot">
+                        
+                        Mavibot
+                        
+                    </a>
+                    &nbsp;|&nbsp;
+                    <a href="./../../escimo">
+                        
+                        eSCIMo
+                        
+                    </a>
+                    &nbsp;|&nbsp;
+                    <a href="./../../fortress">
+                        
+                        Fortress
+                        
+                    </a>
+                    &nbsp;|&nbsp;
+                    <a href="./../../kerby">
+                        
+                        Kerby
+                        
+                    </a>
+                </div><!-- subProjectsNavBar -->
+            </div><!-- header -->
+            <div id="content">
+                <div id="leftColumn">
+                    
+<div id="navigation">
+    
+    <!--ul>
+      <li>
+        <a href="http://bit.ly/1n9YlQT" target="_blank">
+          <img src="./../../images/ApacheConBudapest.png" width="125" height="125" alt="I'm Speaking at ApacheCon Europe 2014! Join me!" title="I'm Speaking at ApacheCon Europe 2014! Join me!" border="0" style="margin-bottom:-3px;"/>
+        </a>
+      </li>
+    </ul-->
+    <h5>ApacheDS 2.0</h5>
+    <ul>
+        <li><a href="./../../apacheds/">Home</a></li>
+        <li><a href="./../../apacheds/news.html">News</a></li>
+        <li><a href="./../../apacheds/features.html">Features</a></li>
+    </ul>
+    <h5>Downloads</h5>
+    <ul>
+        <li><a href="./../../apacheds/downloads.html">ApacheDS 2.0.0-M21</a>&nbsp;&nbsp;<img src="./../../images/new_badge.gif" alt="" style="margin-bottom:-3px;" border="0"></li>
+        <li><a href="./../../apacheds/download-old-versions.html">Older versions</a></li>
+    </ul>
+    <h5>Documentation</h5>
+    <ul>
+        <li><a href="./../../apacheds/basic-user-guide.html">Basic User Guide </a></li>
+        <li><a href="./../../apacheds/advanced-user-guide.html">Advanced User Guide</a></li>
+        <li><a href="./../../apacheds/developer-guide.html">Developer Guide</a></li>
+        <li><a href="./../../apacheds/kerberos-user-guide.html">Kerberos User Guide</a></li>
+        <li><a href="./../../apacheds/configuration/ads-2.0-configuration.html">Configuration</a></li>
+        <li><a href="./../../apacheds/gen-docs/latest/apidocs">JavaDocs</a></li>
+        <li><a href="./../../apacheds/gen-docs/latest/xref">Cross-Reference</a></li>
+    </ul>
+    
+    
+    <h5>Support</h5>
+    <ul>
+        <li><a href="./../../mailing-lists-and-irc.html">Mailing Lists &amp; IRC</a></li>
+        <li><a href="./../../sources.html">Sources</a></li>
+        <li><a href="./../../issue-tracking.html">Issue Tracking</a></li>
+        <li><a href="./../../commercial-support.html">Commercial Support</a></li>
+    </ul>
+    <h5>Community</h5>
+    <ul>
+        <li><a href="./../../contribute.html">How to Contribute</a></li>
+        <li><a href="./../../team.html">Team</a></li>
+        <li><a href="./../../original-project-proposal.html">Original Project Proposal</a></li>
+        <li><a href="./../../special-thanks.html" class="external-link" rel="nofollow">Special Thanks</a></li>
+    </ul>
+    <h5>About Apache</h5>
+    <ul>
+        <li><a href="http://www.apache.org/">Apache</a></li>
+        <li><a href="http://www.apache.org/licenses/">License</a></li>
+        <li><a href="http://www.apache.org/foundation/sponsorship.html">Sponsorship</a></li>
+        <li><a href="http://www.apache.org/foundation/thanks.html">Thanks</a></li>
+        <li><a href="http://www.apache.org/security/">Security</a></li>
+    </ul>
+    
+</div><!-- navigation -->
+
+                </div><!-- leftColumn -->
+                <div id="rightColumn">
+
+
+    <div class="nav">
+        <div class="nav_prev">
+        
+            <a href="7-embedding-apacheds.html">7 - Embedding ApacheDS in Java</a>
+		
+        </div>
+        <div class="nav_up">
+        
+            <a href="../advanced-user-guide.html">Advanced User Guide</a>
+		
+        </div>
+        <div class="nav_next">
+        
+			&nbsp;
+        
+        </div>
+        <div class="clearfix"></div>
+    </div>
+
+
+<style type="text/css">
+/* The following code is added by mdx_elementid.py
+   It was originally lifted from http://subversion.apache.org/style/site.css */
+/*
+ * Hide class="elementid-permalink", except when an enclosing heading
+ * has the :hover property.
+ */
+.headerlink, .elementid-permalink {
+  visibility: hidden;
+}
+h2:hover > .headerlink, h3:hover > .headerlink, h1:hover > .headerlink, h6:hover > .headerlink, h4:hover > .headerlink, h5:hover > .headerlink, dt:hover > .elementid-permalink { visibility: visible }</style>
+<h1 id="8-operational-attributes">8 - Operational Attributes<a class="headerlink" href="#8-operational-attributes" title="Permanent link">&para;</a></h1>
+<p>Operational attributes are attributes that are used internally by the server. They generally can't be modified by a user, although one can read them.</p>
+<p>In order to retrieve an operational attribute, you have to require it explicitely, or request all of them using the special attribute '+'.</p>
+<p><a href="https://tools.ietf.org/html/rfc4512">RFC 4512</a> defines four different flavors of <strong>AttributeType</strong> :</p>
+<ul>
+<li>userApplications : User's attributes</li>
+<li>directoryOperation : Server's attributes</li>
+<li>dSAOperation : Server's attributes that have no meant in being distributed</li>
+<li>distributedOperation : Server's attribute that are used in a distributed environment</li>
+</ul>
+<p>ApacheDS support a list of standard LDAP operational attributes, plus a few that are specific. Here are the supported operational attributes.</p>
+<h2 id="global-operational-attributes">Global operational attributes<a class="headerlink" href="#global-operational-attributes" title="Permanent link">&para;</a></h2>
+<p>Those operational attributes are stored in the <strong>RootDSE</strong>, and global to the server. They can't be modified by a user.</p>
+<p>|| Attribute name || Type || Category || Description ||
+| vendorName | DSA OPERATION | Standard  | RFC3045: name of implementation vendor |
+| vendorVersion | DSA OPERATION | Standard  | RFC3045: version of implementation |
+| entryTtl | DSA OPERATION | Standard  | RFC2589: entry time-to-live |
+| dynamicSubtrees | DSA OPERATION | Standard  | RFC2589: dynamic subtrees |
+| supportedFeatures | DSA OPERATION | Standard  | RFC3674: features supported by the server |
+| supportedControl | DSA OPERATION | Standard  | RFC2252: supported controls |
+| supportedSASLMechanisms | DSA OPERATION | Standard  | RFC2252: supported SASL mechanisms |
+| supportedLDAPVersion | DSA OPERATION | Standard  | RFC2252: supported LDAP versions |
+| namingContexts | DSA OPERATION | Standard  | RFC2252: naming contexts |
+| altServer | DSA OPERATION | Standard  | RFC2252: alternative servers |
+| supportedExtension | DSA OPERATION | Standard  | RFC2252: supported extended operations |</p>
+<h2 id="entry-operational-attributes">Entry operational attributes<a class="headerlink" href="#entry-operational-attributes" title="Permanent link">&para;</a></h2>
+<p>Those are attributes related to an entry, carrying some additional information about it</p>
+<p>|| Attribute name || Type || Category || Description ||
+| createTimestamp | DIRECTORY OPERATION | Standard |  RFC2252: time which object was created |
+| modifyTimestamp | DIRECTORY OPERATION | Standard  | RFC2252: time which object was last modified |
+| creatorsName | DIRECTORY OPERATION | Standard  | RFC2252: name of creator |
+| modifiersName | DIRECTORY OPERATION | Standard  | RFC2252: name of last modifier |
+| hasSubordinates | DIRECTORY OPERATION | Standard  | X.501: entry has children |
+| ref | DISTRIBUTED OPERATION | Standard  | RFC3296: named reference - a labeledURI |
+| entryUUID | DIRECTORY OPERATION | ApacheDS | UUID of the entry |
+| entryDN | DIRECTORY OPERATION | ApacheDS  | DN of the entry |
+| entryCSN | DIRECTORY OPERATION | ApacheDS  | Change sequence number of the entry |
+| nbChildren | DIRECTORY OPERATION | ApacheDS  | The number of children for this entry |
+| nbSubordinates | DIRECTORY OPERATION | ApacheDS  | The number of subordinates for this entry |
+| entryParentId | DIRECTORY OPERATION | ApacheDS  | Attribute holding the id of parent entry |</p>
+<h2 id="schema-related-operational-attributes">Schema related operational attributes<a class="headerlink" href="#schema-related-operational-attributes" title="Permanent link">&para;</a></h2>
+<p>Those operational attributes are containing the schema elements handled by the server. They are stored in the <strong>RootDSE</strong></p>
+<p>|| Attribute name || Type || Category || Description ||
+| ldapSyntaxes | DIRECTORY OPERATION | Standard | RFC2252: LDAP syntaxes | 
+| subschemaSubentry | DIRECTORY OPERATION | Standard | RFC2252: name of controlling subschema entry | 
+| dITStructureRules | DIRECTORY OPERATION | Standard | RFC2252: DIT structure rules | 
+| dITContentRules | DIRECTORY OPERATION | Standard | RFC2252: DIT content rules | 
+| matchingRules | DIRECTORY OPERATION | Standard | RFC2252: matching rules | 
+| attributeTypes | DIRECTORY OPERATION | Standard | RFC2252: attribute types | 
+| objectClasses | DIRECTORY OPERATION | Standard | RFC2252: object classes | 
+| nameForms | DIRECTORY OPERATION | Standard | RFC2252: Name Forms | 
+| matchingRuleUse | DIRECTORY OPERATION | Standard | RFC2252: matching rule uses | 
+| structuralObjectClass | DIRECTORY OPERATION | Standard | X.500(93): structural object class of entry | 
+| comparators | DIRECTORY OPERATION | ApacheDS  | A multivalued comparator description attribute |
+| normalizers | DIRECTORY OPERATION | ApacheDS  | A multivalued normalizer description attribute |
+| syntaxCheckers | DIRECTORY OPERATION | ApacheDS  | A multivalued syntaxCheckers description attribute |
+| schemaModifyTimestamp | DIRECTORY OPERATION | ApacheDS  | Time which schema was modified |
+| schemaModifiersName | DIRECTORY OPERATION | ApacheDS  | The DN of the modifier of the schema |</p>
+<h2 id="collective-attributes-operational-attributes">Collective Attributes operational attributes<a class="headerlink" href="#collective-attributes-operational-attributes" title="Permanent link">&para;</a></h2>
+<p>Those are attributes related to collective attributes.</p>
+<p>|| Attribute name || Type || Category || Description ||
+| collectiveAttributeSubentries | DIRECTORY OPERATION | Standard | RFC3671: identifies all collective attribute subentries that affect the entry |
+| collectiveExclusions | DIRECTORY OPERATION | Standard | RFC3671: RFC3671: allows particular collective attributes to be excluded from an entry |</p>
+<h2 id="administrative-model-attributes">Administrative Model Attributes<a class="headerlink" href="#administrative-model-attributes" title="Permanent link">&para;</a></h2>
+<p>Those are attributes related to the Administrative Model management</p>
+<p>|| Attribute name || Type || Category || Description ||
+| administrativeRole | DIRECTORY OPERATION | Standard  | RFC3672: indicate that the associated administrative area is concerned withone or more administrative roles |
+| subtreeSpecification | DIRECTORY OPERATION | Standard  | RFC3672: defines a collection of entries within an administrative area |
+| prescriptiveACI | DIRECTORY OPERATION | ApacheDS  | Access control information that applies to a set of entries |
+| entryACI | DIRECTORY OPERATION | ApacheDS  | Access control information that applies to a single entry |
+| subentryACI | DIRECTORY OPERATION | ApacheDS  | Access control information that applies to a single subentry |
+| autonomousAreaSubentry | DIRECTORY OPERATION | ApacheDS  | Used to track a subentry associated with an autonomousArea |
+| accessControlSubentries | DIRECTORY OPERATION | ApacheDS  | Used to track a subentry associated with access control areas |</p>
+<h2 id="replication-related-operational-attributes">Replication related operational attributes<a class="headerlink" href="#replication-related-operational-attributes" title="Permanent link">&para;</a></h2>
+<p>Those attributes are used in a replication context.</p>
+<p>|| Attribute name || Type || Category || Description ||
+| contextCSN | DIRECTORY OPERATION | ApacheDS  | The largest committed CSN of a context |
+| entryDeleted | DIRECTORY OPERATION | ApacheDS  | Whether or not an entry has been deleted. (Not anymore used) |</p>
+<h2 id="index-related-operational-attributes">Index related operational attributes<a class="headerlink" href="#index-related-operational-attributes" title="Permanent link">&para;</a></h2>
+<p>Those operational attributes are used to define the various system predefined indexes</p>
+<p>|| Attribute name || Type || Category || Description ||
+| apachePresence | DSA OPERATION | ApacheDS  | Index attribute used to track the existence of attributes |
+| apacheOneLevel | DSA OPERATION | ApacheDS  | Index attribute used to track one level searches |
+| apacheOneAlias | DSA OPERATION | ApacheDS  | Index attribute used to track single level aliases |
+| apacheSubAlias | DSA OPERATION | ApacheDS  | Index attribute used to track sub level aliases |
+| apacheAlias | DSA OPERATION | ApacheDS  | Index attribute used to track aliases |
+| apacheSubLevel | DSA OPERATION | ApacheDS  | Index attribute used to track sub level searches |
+| apacheRdn | DSA OPERATION | ApacheDS  | Index attribute RDN with values both user provided and normalized based on schema |</p>
+<h2 id="trigger-interceptor-model-attributes">Trigger interceptor Model Attributes<a class="headerlink" href="#trigger-interceptor-model-attributes" title="Permanent link">&para;</a></h2>
+<p>Those are attributes used in the Trigger Interceptor</p>
+<p>| prescriptiveTriggerSpecification | DIRECTORY OPERATION | ApacheDS  | Trigger specification that applies to a set of entries |
+| entryTriggerSpecification | DIRECTORY OPERATION | ApacheDS  | Trigger specification that applies to a single entry |
+| triggerExecutionSubentries | DIRECTORY OPERATION | ApacheDS  | Used to track subentries associated with a trigger area which an entry falls under |</p>
+<h2 id="changelog-related-operational-attributes">ChangeLog related operational attributes<a class="headerlink" href="#changelog-related-operational-attributes" title="Permanent link">&para;</a></h2>
+<p>Those operational attributes are meant to be used by teh <strong>ChangeLog</strong> interceptor. They are not supposed to be distributed, and they can't be modified by a user.</p>
+<p>|| Attribute name || Type || Category || Description ||
+| revisions | DSA OPERATION | ApacheDS  | Revision numbers used in change log |
+| changeTime | DSA OPERATION | ApacheDS  | Represents the time when the change event occurred |
+| changeType | DSA OPERATION | ApacheDS  | Type of change operation |
+| eventId | DSA OPERATION | ApacheDS  | The unique sequential id for the event (a.k.a revision number) |
+| committer | DSA OPERATION | ApacheDS  | The principal committing the change |
+| changeLogContext | DSA OPERATION | ApacheDS  | Tells about the changelog context suffix |</p>
+
+
+    <div class="nav">
+        <div class="nav_prev">
+        
+            <a href="7-embedding-apacheds.html">7 - Embedding ApacheDS in Java</a>
+		
+        </div>
+        <div class="nav_up">
+        
+            <a href="../advanced-user-guide.html">Advanced User Guide</a>
+		
+        </div>
+        <div class="nav_next">
+        
+			&nbsp;
+        
+        </div>
+        <div class="clearfix"></div>
+    </div>
+
+
+                </div><!-- rightColumn -->
+                <div id="endContent"></div>
+            </div><!-- content -->
+            <div id="footer">&copy; 2003-2015, <a href="http://www.apache.org">The Apache Software Foundation</a> - <a href="./../../privacy-policy.html">Privacy Policy</a><br />
+                Apache Directory, ApacheDS, Apache Directory Server, Apache Directory Studio, Apache LDAP API, Apache Triplesec, Triplesec, Apache Mavibot, Mavibot, Apache eSCIMo, eSCIMo, Fortress, Apache Fortress, EnMasse, Apache EnMasse, Apache Kerby, Kerby
+                Apache, the Apache feather logo, and the Apache Directory project logos are trademarks of The Apache Software Foundation.
+            </div>
+        </div><!-- container -->
+    </body>
+</html>
\ No newline at end of file

Modified: websites/staging/directory/trunk/content/apacheds/advanced-user-guide.html
==============================================================================
--- websites/staging/directory/trunk/content/apacheds/advanced-user-guide.html (original)
+++ websites/staging/directory/trunk/content/apacheds/advanced-user-guide.html Mon Mar  7 11:29:48 2016
@@ -263,6 +263,7 @@ h2:hover > .headerlink, h3:hover > .head
 </li>
 <li><a href="advanced-ug/6-implementing-interceptor.html">6 - Implementing a simple custom Interceptor for ApacheDS</a></li>
 <li><a href="advanced-ug/7-embedding-apacheds.html">7 - Embedding ApacheDS in Java</a></li>
+<li><a href="advanced-ug/8-operational-attributes.html">8 - Operational Attributes</a></li>
 </ul>