You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@commons.apache.org by robert burrell donkin <ro...@blueyonder.co.uk> on 2002/12/05 21:26:09 UTC

[lang] MethodUtils method naming

in beanutils, methods called 'getAccessibleMethod' (or variations) are 
used to get methods which can safely be called through reflection. this 
seems a little at odds with the use of the term 'accessible' in the 
java.lang.reflect which means that the object suppresses the standard java 
access rules.

is this confusing?

and - if so - does anyone have any better names?

- robert


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: [lang] MethodUtils method naming

Posted by robert burrell donkin <ro...@blueyonder.co.uk>.
i've taken a look and only one of these methods is actually going to be 
needed. this is the one that takes an existing method and then finds a 
compatible method that can be safely called by reflection. it's used in 
beanutils and also by the bug workaround code.

i'll probably rename it to getMethod.

- robert

On Thursday, December 5, 2002, at 10:16 PM, Stephen Colebourne wrote:

> I thought this was just going to be getMethod()?
>
> With your changes how many names do we need? I thought there were just 
> two:
> - normal   (getMethod ?)
> - ignoring scope  (getMethodIgnoringScope ???)
>
> Stephen
>
>
> ----- Original Message -----
> From: "robert burrell donkin" <ro...@blueyonder.co.uk>
> To: "Jakarta Commons Developers List" <co...@jakarta.apache.org>
> Sent: Thursday, December 05, 2002 8:26 PM
> Subject: [lang] MethodUtils method naming
>
>
>> in beanutils, methods called 'getAccessibleMethod' (or variations) are
>> used to get methods which can safely be called through reflection. this
>> seems a little at odds with the use of the term 'accessible' in the
>> java.lang.reflect which means that the object suppresses the standard 
>> java
>> access rules.
>>
>> is this confusing?
>>
>> and - if so - does anyone have any better names?
>>
>> - robert
>>
>>
>> --
>> To unsubscribe, e-mail:
> <ma...@jakarta.apache.org>
>> For additional commands, e-mail:
> <ma...@jakarta.apache.org>
>>
>
>
> --
> To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.
> org>
> For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.
> org>
>


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: [lang] MethodUtils method naming

Posted by Stephen Colebourne <sc...@btopenworld.com>.
I thought this was just going to be getMethod()?

With your changes how many names do we need? I thought there were just two:
- normal   (getMethod ?)
- ignoring scope  (getMethodIgnoringScope ???)

Stephen


----- Original Message -----
From: "robert burrell donkin" <ro...@blueyonder.co.uk>
To: "Jakarta Commons Developers List" <co...@jakarta.apache.org>
Sent: Thursday, December 05, 2002 8:26 PM
Subject: [lang] MethodUtils method naming


> in beanutils, methods called 'getAccessibleMethod' (or variations) are
> used to get methods which can safely be called through reflection. this
> seems a little at odds with the use of the term 'accessible' in the
> java.lang.reflect which means that the object suppresses the standard java
> access rules.
>
> is this confusing?
>
> and - if so - does anyone have any better names?
>
> - robert
>
>
> --
> To unsubscribe, e-mail:
<ma...@jakarta.apache.org>
> For additional commands, e-mail:
<ma...@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>