You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "Houston Putman (JIRA)" <ji...@apache.org> on 2014/03/16 22:13:43 UTC

[jira] [Comment Edited] (SOLR-5488) Fix up test failures for Analytics Component

    [ https://issues.apache.org/jira/browse/SOLR-5488?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13937298#comment-13937298 ] 

Houston Putman edited comment on SOLR-5488 at 3/16/14 9:13 PM:
---------------------------------------------------------------

\*\*\* First Problem ***
In the fieldFacets,txt did you change it like this?
turning 'o.min.ff=string_sd' into 'o.min.ff=int_id' and 'o.min.ff=date_dtd' into 'o.min.ff=long_ld'

If so that doesn't really make since. Because these are calculating the minimum integer value faceting over the string values, and the minimum long value faceting over the date values. If you made the changes above, then you would be calculating the mininum int value faceting over all of the int values, etc. So the change isn't a good test even if it passes.
*************************

\*\*\* Second Problem ***
So the ordering is somewhat important. Solr, and the analytics component, automatically sort the results of field facet by the field being faceted on. I assumed this when writing the tests so if the results are coming back misordered, then either the test is either splitting up the values incorrectly or the analytics component is. Or the sorting gets mesed up somewhere in the test. I don't think the sorting is an issue in the component.

Looking through the test code, a lot has been changed from what I wrote. The part that I don't recognize at all is the parsing of the response through methods like getDoubleList() etc. in AbstractAnalyticsFacetTest.java. Since the tests worked before those methods were changed, I would suggest looking at those parsing methods first. 

(Side note: the methods in FieldFacetTest.java that still have FacetAsc, like medianFacetAscTest and sumOfSquaresFacetAscTest, should be renamed without the FacetAsc part so that they are named like the rest of the methods. (The FacetAsc functionality was taken out a while ago.) So the methods mentioned above should be renamed to medianTest and sumOfSquaresTest, respectively, in addition to the similarly named methods.
*****************************

I would highly discourage you from changing the patterns in the fieldFacets.txt. I had trouble keeping all of that stuff straight while writing it and I don't think that is where the issue is. 

I'm not able to run the tests right now, so that's all of the help I can give.


was (Author: houstonputman):
*** First Problem ***
In the fieldFacets,txt did you change it like this?
turning 'o.min.ff=string_sd' into 'o.min.ff=int_id' and 'o.min.ff=date_dtd' into 'o.min.ff=long_ld'

If so that doesn't really make since. Because these are calculating the minimum integer value faceting over the string values, and the minimum long value faceting over the date values. If you made the changes above, then you would be calculating the mininum int value faceting over all of the int values, etc. So the change isn't a good test even if it passes.
*************************

*** Second Problem ***
So the ordering is somewhat important. Solr, and the analytics component, automatically sort the results of field facet by the field being faceted on. I assumed this when writing the tests so if the results are coming back misordered, then either the test is either splitting up the values incorrectly or the analytics component is. Or the sorting gets mesed up somewhere in the test. I don't think the sorting is an issue in the component.

Looking through the test code, a lot has been changed from what I wrote. The part that I don't recognize at all is the parsing of the response through methods like getDoubleList() etc. in AbstractAnalyticsFacetTest.java. Since the tests worked before those methods were changed, I would suggest looking at those parsing methods first. 

(Side note: the methods in FieldFacetTest.java that still have FacetAsc, like medianFacetAscTest and sumOfSquaresFacetAscTest, should be renamed without the FacetAsc part so that they are named like the rest of the methods. (The FacetAsc functionality was taken out a while ago.) So the methods mentioned above should be renamed to medianTest and sumOfSquaresTest, respectively, in addition to the similarly named methods.
*****************************

I would highly discourage you from changing the patterns in the fieldFacets.txt. I had trouble keeping all of that stuff straight while writing it and I don't think that is where the issue is. 

I'm not able to run the tests right now, so that's all of the help I can give.

> Fix up test failures for Analytics Component
> --------------------------------------------
>
>                 Key: SOLR-5488
>                 URL: https://issues.apache.org/jira/browse/SOLR-5488
>             Project: Solr
>          Issue Type: Bug
>    Affects Versions: 4.7, 5.0
>            Reporter: Erick Erickson
>            Assignee: Erick Erickson
>         Attachments: SOLR-5488.patch, SOLR-5488.patch, SOLR-5488.patch, SOLR-5488.patch, SOLR-5488.patch, SOLR-5488.patch, SOLR-5488.patch, eoe.errors
>
>
> The analytics component has a few test failures, perhaps environment-dependent. This is just to collect the test fixes in one place for convenience when we merge back into 4.x



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org