You are viewing a plain text version of this content. The canonical link for it is here.
Posted to derby-dev@db.apache.org by "Knut Anders Hatlen (JIRA)" <ji...@apache.org> on 2012/05/25 13:58:23 UTC
[jira] [Updated] (DERBY-5783) Remove duplicated code for starting
remote processes in replication tests
[ https://issues.apache.org/jira/browse/DERBY-5783?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Knut Anders Hatlen updated DERBY-5783:
--------------------------------------
Attachment: d5783-1a.diff
The attached patch replaces two calls to the three-arg runUserCommandRemotely() method with calls to the four-arg variant of the method, and removes three methods that become unused because of the change.
Replication tests passed with the patch.
> Remove duplicated code for starting remote processes in replication tests
> -------------------------------------------------------------------------
>
> Key: DERBY-5783
> URL: https://issues.apache.org/jira/browse/DERBY-5783
> Project: Derby
> Issue Type: Improvement
> Components: Test
> Affects Versions: 10.10.0.0
> Reporter: Knut Anders Hatlen
> Assignee: Knut Anders Hatlen
> Priority: Minor
> Attachments: d5783-1a.diff
>
>
> ReplicationRun has two copies of each of the methods runUserCommand(), runUserCommandRemotely() and processOutput(). One variant takes an id parameter (used only in debug output), and one doesn't. It would be sufficient to have one copy of each of these methods.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira