You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@directory.apache.org by Trustin Lee <tr...@gmail.com> on 2006/06/04 09:52:11 UTC

ReferenceCountingIoFilter vs ReferenceCountingIoFilterWrapper (Was: Re: svn commit: r411055 - in /directory/trunks/mina/core/src/main/java/org/apache/mina/common: IoFilter.java ReferenceCountingIoFilter.java ReferenceCountingIoFilterWrapper.java)

On 6/3/06, peter royal <pr...@apache.org> wrote:
>
> On Jun 2, 2006, at 1:57 AM, trustin@apache.org wrote:
> > * Renamed ReferenceCountingIoFilterWrapper to
> > ReferenceCountingIoFilter
>
> Do we not want to call it a *Wrapper or *Decorator to indicate that
> it is a filter that will wrap another filter? I've always been in
> favor of doing that to make the usage of a class clear from its name...


Did we discussed about this naming scheme before?  Please blame my brain if
so. :)

I just thought that it is OK to omit the name of the pattern because we have
JavaDoc that can explain what it does in one sentence.  It is because using
the class means that we know what it does.  From the readibiliy viewpoint,
we can easily guess that it's a wrapper or a decorator because there's
another filter as a constructor parameter.  So I think it's fine to omit
Wrapper or Decorator in class names.

But this is only my opinion.  Let's discuss enough to get to the concensus.

Thanks for pointing out,
Trustin
-- 
what we call human nature is actually human habit
--
http://gleamynode.net/
--
PGP key fingerprints:
* E167 E6AF E73A CBCE EE41  4A29 544D DE48 FE95 4E7E
* B693 628E 6047 4F8F CFA4  455E 1C62 A7DC 0255 ECA6

Re: ReferenceCountingIoFilter vs ReferenceCountingIoFilterWrapper (Was: Re: svn commit: r411055 - in /directory/trunks/mina/core/src/main/java/org/apache/mina/common: IoFilter.java ReferenceCountingIoFilter.java ReferenceCountingIoFilterWrapper.java)

Posted by Trustin Lee <tr...@gmail.com>.
I am sorry for sending this message to dev@directory.  Please ignore it and
reply to the message sent to mina-dev@directory if you're interested.

Apologies,
Trustin

On 6/4/06, Trustin Lee <tr...@gmail.com> wrote:
>
> On 6/3/06, peter royal <pr...@apache.org> wrote:
> >
> > On Jun 2, 2006, at 1:57 AM, trustin@apache.org wrote:
> > > * Renamed ReferenceCountingIoFilterWrapper to
> > > ReferenceCountingIoFilter
> >
> > Do we not want to call it a *Wrapper or *Decorator to indicate that
> > it is a filter that will wrap another filter? I've always been in
> > favor of doing that to make the usage of a class clear from its name...
>
>
> Did we discussed about this naming scheme before?  Please blame my brain
> if so. :)
>
> I just thought that it is OK to omit the name of the pattern because we
> have JavaDoc that can explain what it does in one sentence.  It is because
> using the class means that we know what it does.  From the readibiliy
> viewpoint, we can easily guess that it's a wrapper or a decorator because
> there's another filter as a constructor parameter.  So I think it's fine to
> omit Wrapper or Decorator in class names.
>
> But this is only my opinion.  Let's discuss enough to get to the
> concensus.
>
> Thanks for pointing out,
> Trustin
>

Trustin
-- 
what we call human nature is actually human habit
--
http://gleamynode.net/
--
PGP key fingerprints:
* E167 E6AF E73A CBCE EE41  4A29 544D DE48 FE95 4E7E
* B693 628E 6047 4F8F CFA4  455E 1C62 A7DC 0255 ECA6

Re: ReferenceCountingIoFilter vs ReferenceCountingIoFilterWrapper (Was: Re: svn commit: r411055 - in /directory/trunks/mina/core/src/main/java/org/apache/mina/common: IoFilter.java ReferenceCountingIoFilter.java ReferenceCountingIoFilterWrapper.java)

Posted by Maarten Bosteels <mb...@gmail.com>.
I tend to agree with Trustin on this one,

Maarten

On 6/14/06, peter royal <pr...@apache.org> wrote:
> On Jun 4, 2006, at 3:53 AM, Trustin Lee wrote:
> > On 6/3/06, peter royal <pr...@apache.org> wrote:
> >>
> >> On Jun 2, 2006, at 1:57 AM, trustin@apache.org wrote:
> >> > * Renamed ReferenceCountingIoFilterWrapper to
> >> > ReferenceCountingIoFilter
> >>
> >> Do we not want to call it a *Wrapper or *Decorator to indicate that
> >> it is a filter that will wrap another filter? I've always been in
> >> favor of doing that to make the usage of a class clear from its
> >> name...
> >
> >
> > Did we discussed about this naming scheme before?  Please blame my
> > brain if
> > so. :)
> >
> > I just thought that it is OK to omit the name of the pattern
> > because we have
> > JavaDoc that can explain what it does in one sentence.  It is
> > because using
> > the class means that we know what it does.  From the readibiliy
> > viewpoint,
> > we can easily guess that it's a wrapper or a decorator because there's
> > another filter as a constructor parameter.  So I think it's fine to
> > omit
> > Wrapper or Decorator in class names.
> >
> > But this is only my opinion.  Let's discuss enough to get to the
> > concensus.
>
> Anyone else have an opinion? (If no-one does, we can leave as-is..)
> -pete
>
> --
> proyal@apache.org - http://fotap.org/~osi
>
>
>
>
>

Re: ReferenceCountingIoFilter vs ReferenceCountingIoFilterWrapper (Was: Re: svn commit: r411055 - in /directory/trunks/mina/core/src/main/java/org/apache/mina/common: IoFilter.java ReferenceCountingIoFilter.java ReferenceCountingIoFilterWrapper.java)

Posted by peter royal <pr...@apache.org>.
On Jun 4, 2006, at 3:53 AM, Trustin Lee wrote:
> On 6/3/06, peter royal <pr...@apache.org> wrote:
>>
>> On Jun 2, 2006, at 1:57 AM, trustin@apache.org wrote:
>> > * Renamed ReferenceCountingIoFilterWrapper to
>> > ReferenceCountingIoFilter
>>
>> Do we not want to call it a *Wrapper or *Decorator to indicate that
>> it is a filter that will wrap another filter? I've always been in
>> favor of doing that to make the usage of a class clear from its  
>> name...
>
>
> Did we discussed about this naming scheme before?  Please blame my  
> brain if
> so. :)
>
> I just thought that it is OK to omit the name of the pattern  
> because we have
> JavaDoc that can explain what it does in one sentence.  It is  
> because using
> the class means that we know what it does.  From the readibiliy  
> viewpoint,
> we can easily guess that it's a wrapper or a decorator because there's
> another filter as a constructor parameter.  So I think it's fine to  
> omit
> Wrapper or Decorator in class names.
>
> But this is only my opinion.  Let's discuss enough to get to the  
> concensus.

Anyone else have an opinion? (If no-one does, we can leave as-is..)
-pete

-- 
proyal@apache.org - http://fotap.org/~osi



ReferenceCountingIoFilter vs ReferenceCountingIoFilterWrapper (Was: Re: svn commit: r411055 - in /directory/trunks/mina/core/src/main/java/org/apache/mina/common: IoFilter.java ReferenceCountingIoFilter.java ReferenceCountingIoFilterWrapper.java)

Posted by Trustin Lee <tr...@gmail.com>.
On 6/3/06, peter royal <pr...@apache.org> wrote:
>
> On Jun 2, 2006, at 1:57 AM, trustin@apache.org wrote:
> > * Renamed ReferenceCountingIoFilterWrapper to
> > ReferenceCountingIoFilter
>
> Do we not want to call it a *Wrapper or *Decorator to indicate that
> it is a filter that will wrap another filter? I've always been in
> favor of doing that to make the usage of a class clear from its name...


Did we discussed about this naming scheme before?  Please blame my brain if
so. :)

I just thought that it is OK to omit the name of the pattern because we have
JavaDoc that can explain what it does in one sentence.  It is because using
the class means that we know what it does.  From the readibiliy viewpoint,
we can easily guess that it's a wrapper or a decorator because there's
another filter as a constructor parameter.  So I think it's fine to omit
Wrapper or Decorator in class names.

But this is only my opinion.  Let's discuss enough to get to the concensus.

Thanks for pointing out,
Trustin
-- 
what we call human nature is actually human habit
--
http://gleamynode.net/
--
PGP key fingerprints:
* E167 E6AF E73A CBCE EE41  4A29 544D DE48 FE95 4E7E
* B693 628E 6047 4F8F CFA4  455E 1C62 A7DC 0255 ECA6