You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@flink.apache.org by "Rui Fan (Jira)" <ji...@apache.org> on 2023/12/04 02:43:00 UTC
[jira] [Created] (FLINK-33731) failover.flip1 package can be rename to failover
Rui Fan created FLINK-33731:
-------------------------------
Summary: failover.flip1 package can be rename to failover
Key: FLINK-33731
URL: https://issues.apache.org/jira/browse/FLINK-33731
Project: Flink
Issue Type: Technical Debt
Components: Runtime / Coordination
Affects Versions: 1.17.2, 1.18.0
Reporter: Rui Fan
Assignee: Rui Fan
Fix For: 1.19.0
Currently, there is a org.apache.flink.runtime.executiongraph.failover.flip1 package.
I propose rename the failover.flip1 to failover, in the other word: removing the flip1. I have 2 reasons:
* The naming of the package should be based on business semantics, not FLIP number, and the code under the failover.flip1 package has also many changes after FLIP-1.
* All code under the failover.flip1 package are Internal code instead @Public code, so they can be renamed directly.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)