You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@brpc.apache.org by Wang Weibing <ww...@apache.org> on 2023/10/16 02:00:08 UTC
CVE-2023-45757: Apache bRPC: The builtin service rpcz page has an XSS attack vulnerability
Severity: important
Affected versions:
- Apache bRPC 0.9.0 through 1.6.0
Description:
Security vulnerability in Apache bRPC <=1.6.0 on all platforms allows attackers to inject XSS code to the builtin rpcz page.
An attacker that can send http request to bRPC server with rpcz enabled can inject arbitrary XSS code to the builtin rpcz page.
Solution (choose one of three):
1. upgrade to bRPC > 1.6.0, download link: https://dist.apache.org/repos/dist/release/brpc/1.6.1/
2. If you are using an old version of bRPC and hard to upgrade, you can apply this patch: https://github.com/apache/brpc/pull/2411
3. disable rpcz feature
References:
https://brpc.apache.org
https://www.cve.org/CVERecord?id=CVE-2023-45757
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@brpc.apache.org
For additional commands, e-mail: dev-help@brpc.apache.org