You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "Uwe Schindler (JIRA)" <ji...@apache.org> on 2016/02/28 13:28:19 UTC

[jira] [Comment Edited] (LUCENE-7053) Remove deprecated BytesRef#getUTF8SortedAsUTF16Comparator()

    [ https://issues.apache.org/jira/browse/LUCENE-7053?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15171021#comment-15171021 ] 

Uwe Schindler edited comment on LUCENE-7053 at 2/28/16 12:27 PM:
-----------------------------------------------------------------

New patch:
- I removed some usage of comparator and replaced by {{compareTo}} at many places.
- Moved the code of the comparator to {{compareTo}}.
- The comparator isstelf is now a static final constant {{BytesRef.COMPARATOR}} (the name was horrible). It is documented to just order by bytes. In fact its just a method reference to the {{compareTo}} method!
- I also removed the chicken-egg statement in FuzzyQuery.


was (Author: thetaphi):
New patch:
- I removed useless usage of comparator at some places and replace by compareTo
- Moved the code of the comparator to compareTo.
- The comparator isstelf is now a static constant BytesRef.COMPARATOR (the name was horrible). It is documented to just order by bytes. In fact its just a method reference to the compareTo method!
- I also removed the chicken-egg statement in FuzzyQuery

> Remove deprecated BytesRef#getUTF8SortedAsUTF16Comparator()
> -----------------------------------------------------------
>
>                 Key: LUCENE-7053
>                 URL: https://issues.apache.org/jira/browse/LUCENE-7053
>             Project: Lucene - Core
>          Issue Type: Improvement
>          Components: core/other
>            Reporter: Uwe Schindler
>            Assignee: Uwe Schindler
>             Fix For: master, 6.0
>
>         Attachments: LUCENE-7053.patch, LUCENE-7053.patch, LUCENE-7053.patch
>
>
> Followup from LUCENE-7052: This removes the legacy, deprecated getUTF8SortedAsUTF16Comparator() in the BytesRef class. The only left over user was TSTLookup. Moves the code there as private impl detail.
> This also converts the comparators to lambdas for better readability.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org