You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Ufuk Celebi (JIRA)" <ji...@apache.org> on 2016/07/07 13:05:10 UTC
[jira] [Created] (FLINK-4170) Remove `CONFIG_` prefix from
KinesisConfigConstants variables
Ufuk Celebi created FLINK-4170:
----------------------------------
Summary: Remove `CONFIG_` prefix from KinesisConfigConstants variables
Key: FLINK-4170
URL: https://issues.apache.org/jira/browse/FLINK-4170
Project: Flink
Issue Type: Improvement
Components: Streaming Connectors
Reporter: Ufuk Celebi
Fix For: 1.1.0
I find the static variable names verbose. I think it's clear from context that they refer to the Kinesis configuration since they are all gathered in that class.
Therefore would like to remove the {{CONFIG_}} prefix before the release, so that we have
{code}
conf.put(KinesisConfigConstants.AWS_REGION, "")
{code}
instead of
{code}
conf.put(KinesisConfigConstants.CONFIG_AWS_REGION, "")
{code}
For longer variables it becomes even longer otherwise.
---
Some basic variable names that might be accessed frequently are also very long:
{code}
CONFIG_AWS_CREDENTIALS_PROVIDER_BASIC_SECRETKEY
CONFIG_AWS_CREDENTIALS_PROVIDER_BASIC_ACCESSKEYID
{code}
It might suffice to just have:
{code}
AWS_SECRET_KEY
AWS_ACCESS_KEY
{code}
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)