You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "Jason Rutherglen (JIRA)" <ji...@apache.org> on 2009/07/29 19:14:15 UTC

[jira] Created: (LUCENE-1767) Add sizeof to OpenBitSet

Add sizeof to OpenBitSet
------------------------

                 Key: LUCENE-1767
                 URL: https://issues.apache.org/jira/browse/LUCENE-1767
             Project: Lucene - Java
          Issue Type: Improvement
          Components: Index
    Affects Versions: 2.4.1
            Reporter: Jason Rutherglen
            Priority: Trivial
             Fix For: 2.9


Adding a sizeof method to OpenBitSet will facilitate estimating RAM usage when many OBS' are cached (such as Solr).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


[jira] Commented: (LUCENE-1767) Add sizeof to OpenBitSet

Posted by "Mark Miller (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/LUCENE-1767?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12740034#action_12740034 ] 

Mark Miller commented on LUCENE-1767:
-------------------------------------

I'm about to push this to 3.1 unless someone speaks up

> Add sizeof to OpenBitSet
> ------------------------
>
>                 Key: LUCENE-1767
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1767
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Index
>    Affects Versions: 2.4.1
>            Reporter: Jason Rutherglen
>            Priority: Trivial
>             Fix For: 2.9
>
>         Attachments: LUCENE-1767.patch
>
>   Original Estimate: 2h
>  Remaining Estimate: 2h
>
> Adding a sizeof method to OpenBitSet will facilitate estimating RAM usage when many OBS' are cached (such as Solr).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


[jira] Commented: (LUCENE-1767) Add sizeof to OpenBitSet

Posted by "Simon Willnauer (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/LUCENE-1767?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12736724#action_12736724 ] 

Simon Willnauer commented on LUCENE-1767:
-----------------------------------------

Jason, I would expect a sizeOf method to return the size of the bitset itself (what #size()) returns. Maybe you find another name for that method. I also think you can safely leave the constants out - once you leave those out this method is almost identical to #capacity / #size.

I'm not sure if such a method would rather confuse users / developers. If we add it I would rather go for a very meaningful name like allocatedBytes.

simon

> Add sizeof to OpenBitSet
> ------------------------
>
>                 Key: LUCENE-1767
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1767
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Index
>    Affects Versions: 2.4.1
>            Reporter: Jason Rutherglen
>            Priority: Trivial
>             Fix For: 2.9
>
>         Attachments: LUCENE-1767.patch
>
>   Original Estimate: 2h
>  Remaining Estimate: 2h
>
> Adding a sizeof method to OpenBitSet will facilitate estimating RAM usage when many OBS' are cached (such as Solr).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


[jira] Commented: (LUCENE-1767) Add sizeof to OpenBitSet

Posted by "Mark Miller (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/LUCENE-1767?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12739019#action_12739019 ] 

Mark Miller commented on LUCENE-1767:
-------------------------------------

Anyone have anything to add or any committer want to take this on in the next couple days? If not, I'm going to push it out of 2.9.

> Add sizeof to OpenBitSet
> ------------------------
>
>                 Key: LUCENE-1767
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1767
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Index
>    Affects Versions: 2.4.1
>            Reporter: Jason Rutherglen
>            Priority: Trivial
>             Fix For: 2.9
>
>         Attachments: LUCENE-1767.patch
>
>   Original Estimate: 2h
>  Remaining Estimate: 2h
>
> Adding a sizeof method to OpenBitSet will facilitate estimating RAM usage when many OBS' are cached (such as Solr).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


[jira] Updated: (LUCENE-1767) Add sizeof to OpenBitSet

Posted by "Mark Miller (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/LUCENE-1767?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Mark Miller updated LUCENE-1767:
--------------------------------

    Fix Version/s:     (was: 2.9)
                   3.1

> Add sizeof to OpenBitSet
> ------------------------
>
>                 Key: LUCENE-1767
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1767
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Index
>    Affects Versions: 2.4.1
>            Reporter: Jason Rutherglen
>            Priority: Trivial
>             Fix For: 3.1
>
>         Attachments: LUCENE-1767.patch
>
>   Original Estimate: 2h
>  Remaining Estimate: 2h
>
> Adding a sizeof method to OpenBitSet will facilitate estimating RAM usage when many OBS' are cached (such as Solr).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


[jira] Updated: (LUCENE-1767) Add sizeof to OpenBitSet

Posted by "Jason Rutherglen (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/LUCENE-1767?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jason Rutherglen updated LUCENE-1767:
-------------------------------------

    Attachment: LUCENE-1767.patch

Added sizeOf method

> Add sizeof to OpenBitSet
> ------------------------
>
>                 Key: LUCENE-1767
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1767
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Index
>    Affects Versions: 2.4.1
>            Reporter: Jason Rutherglen
>            Priority: Trivial
>             Fix For: 2.9
>
>         Attachments: LUCENE-1767.patch
>
>   Original Estimate: 2h
>  Remaining Estimate: 2h
>
> Adding a sizeof method to OpenBitSet will facilitate estimating RAM usage when many OBS' are cached (such as Solr).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org