You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@geode.apache.org by Kirk Lund <kl...@pivotal.io> on 2016/07/27 16:54:51 UTC
Renaming GeodePermission
I'm looking at renaming GeodePermission to Permission (see GEODE-1701).
There are a number classes in Geode which import GeodePermission and
Shiro's Permission class:
import org.apache.geode.security.GeodePermission;
import org.apache.shiro.authz.Permission;
I've also been looking at some other implementations of
org.apache.shiro.authz.Permission as well as java.security.Permission. For
example, java.io.FilePermission involves permissions for file system.
I think maybe ResourcePermission would be a better name for GeodePermission
than Permission, because everything GeodePermission involves is Geode
Resources (Cache, Region, Cluster, etc). All of our JMX code uses the term
Resource for any Geode component that is managed.
Honestly, I could go either way: Permission or ResourcePermission. Any
preferences?
Thanks,
Kirk
Re: Renaming GeodePermission
Posted by Bruce Schuchardt <bs...@pivotal.io>.
ResourcePermission seems better to me. "Permission" seems like the name
of an interface.
Le 7/27/2016 � 9:54 AM, Kirk Lund a �crit :
> I'm looking at renaming GeodePermission to Permission (see GEODE-1701).
> There are a number classes in Geode which import GeodePermission and
> Shiro's Permission class:
>
> import org.apache.geode.security.GeodePermission;
> import org.apache.shiro.authz.Permission;
>
> I've also been looking at some other implementations of
> org.apache.shiro.authz.Permission as well as java.security.Permission. For
> example, java.io.FilePermission involves permissions for file system.
>
> I think maybe ResourcePermission would be a better name for GeodePermission
> than Permission, because everything GeodePermission involves is Geode
> Resources (Cache, Region, Cluster, etc). All of our JMX code uses the term
> Resource for any Geode component that is managed.
>
> Honestly, I could go either way: Permission or ResourcePermission. Any
> preferences?
>
> Thanks,
> Kirk
>
Re: Renaming GeodePermission
Posted by Jinmei Liao <ji...@pivotal.io>.
+1 for ResourcePermission
On Wed, Jul 27, 2016 at 10:24 AM, Kenneth Howe <kh...@pivotal.io> wrote:
> +1 to ResourcePermission
>
> Based on your description, this sounds like a better fit for what it does
> than the more general Permission.
>
> > On Jul 27, 2016, at 10:10 AM, Darrel Schneider <ds...@pivotal.io>
> wrote:
> >
> > +1 for ResourcePermission
> >
> > On Wed, Jul 27, 2016 at 9:54 AM, Kirk Lund <kl...@pivotal.io> wrote:
> >
> >> I'm looking at renaming GeodePermission to Permission (see GEODE-1701).
> >> There are a number classes in Geode which import GeodePermission and
> >> Shiro's Permission class:
> >>
> >> import org.apache.geode.security.GeodePermission;
> >> import org.apache.shiro.authz.Permission;
> >>
> >> I've also been looking at some other implementations of
> >> org.apache.shiro.authz.Permission as well as java.security.Permission.
> For
> >> example, java.io.FilePermission involves permissions for file system.
> >>
> >> I think maybe ResourcePermission would be a better name for
> GeodePermission
> >> than Permission, because everything GeodePermission involves is Geode
> >> Resources (Cache, Region, Cluster, etc). All of our JMX code uses the
> term
> >> Resource for any Geode component that is managed.
> >>
> >> Honestly, I could go either way: Permission or ResourcePermission. Any
> >> preferences?
> >>
> >> Thanks,
> >> Kirk
> >>
>
>
--
Cheers
Jinmei
Re: Renaming GeodePermission
Posted by Kenneth Howe <kh...@pivotal.io>.
+1 to ResourcePermission
Based on your description, this sounds like a better fit for what it does than the more general Permission.
> On Jul 27, 2016, at 10:10 AM, Darrel Schneider <ds...@pivotal.io> wrote:
>
> +1 for ResourcePermission
>
> On Wed, Jul 27, 2016 at 9:54 AM, Kirk Lund <kl...@pivotal.io> wrote:
>
>> I'm looking at renaming GeodePermission to Permission (see GEODE-1701).
>> There are a number classes in Geode which import GeodePermission and
>> Shiro's Permission class:
>>
>> import org.apache.geode.security.GeodePermission;
>> import org.apache.shiro.authz.Permission;
>>
>> I've also been looking at some other implementations of
>> org.apache.shiro.authz.Permission as well as java.security.Permission. For
>> example, java.io.FilePermission involves permissions for file system.
>>
>> I think maybe ResourcePermission would be a better name for GeodePermission
>> than Permission, because everything GeodePermission involves is Geode
>> Resources (Cache, Region, Cluster, etc). All of our JMX code uses the term
>> Resource for any Geode component that is managed.
>>
>> Honestly, I could go either way: Permission or ResourcePermission. Any
>> preferences?
>>
>> Thanks,
>> Kirk
>>
Re: Renaming GeodePermission
Posted by Darrel Schneider <ds...@pivotal.io>.
+1 for ResourcePermission
On Wed, Jul 27, 2016 at 9:54 AM, Kirk Lund <kl...@pivotal.io> wrote:
> I'm looking at renaming GeodePermission to Permission (see GEODE-1701).
> There are a number classes in Geode which import GeodePermission and
> Shiro's Permission class:
>
> import org.apache.geode.security.GeodePermission;
> import org.apache.shiro.authz.Permission;
>
> I've also been looking at some other implementations of
> org.apache.shiro.authz.Permission as well as java.security.Permission. For
> example, java.io.FilePermission involves permissions for file system.
>
> I think maybe ResourcePermission would be a better name for GeodePermission
> than Permission, because everything GeodePermission involves is Geode
> Resources (Cache, Region, Cluster, etc). All of our JMX code uses the term
> Resource for any Geode component that is managed.
>
> Honestly, I could go either way: Permission or ResourcePermission. Any
> preferences?
>
> Thanks,
> Kirk
>