You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Dongming Liang (JIRA)" <ji...@apache.org> on 2015/03/03 02:50:04 UTC
[jira] [Work started] (HDFS-1522) Merge Block.BLOCK_FILE_PREFIX and
DataStorage.BLOCK_FILE_PREFIX into one constant
[ https://issues.apache.org/jira/browse/HDFS-1522?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Work on HDFS-1522 started by Dongming Liang.
--------------------------------------------
> Merge Block.BLOCK_FILE_PREFIX and DataStorage.BLOCK_FILE_PREFIX into one constant
> ---------------------------------------------------------------------------------
>
> Key: HDFS-1522
> URL: https://issues.apache.org/jira/browse/HDFS-1522
> Project: Hadoop HDFS
> Issue Type: Bug
> Components: datanode
> Affects Versions: 0.21.0
> Reporter: Konstantin Shvachko
> Assignee: Dongming Liang
>
> Two semantically identical constant {{Block.BLOCK_FILE_PREFIX}} and {{DataStorage.BLOCK_FILE_PREFIX}} should merged into one. Should be defined in {{Block}}, imo.
> Also use cases of "blok_", like in {{DirectoryScanner}} should be replaced by the this constant.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)