You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Zhe Zhang (JIRA)" <ji...@apache.org> on 2015/04/07 20:30:12 UTC
[jira] [Updated] (HDFS-8076) Code cleanup for DFSInputStream: use
offset instead of LocatedBlock when possible
[ https://issues.apache.org/jira/browse/HDFS-8076?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Zhe Zhang updated HDFS-8076:
----------------------------
Status: Patch Available (was: Open)
> Code cleanup for DFSInputStream: use offset instead of LocatedBlock when possible
> ---------------------------------------------------------------------------------
>
> Key: HDFS-8076
> URL: https://issues.apache.org/jira/browse/HDFS-8076
> Project: Hadoop HDFS
> Issue Type: Improvement
> Reporter: Zhe Zhang
> Assignee: Zhe Zhang
> Attachments: HDFS-8076-000.patch
>
>
> This JIRA aims to refactor the signatures {{fetchBlockByteRange}} and {{actualGetFromOneDataNode}}. Instead of taking a {{LocatedBlock}}, I think they should just take the starting offset of that block, since they'll later call {{getBlockAt}} to refresh the location anyway. I think we should make it clear so the callers are not surprised if the finally used {{LocatedBlock}} is not the one they passed in.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)