You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Haejoon Lee (Jira)" <ji...@apache.org> on 2021/06/18 23:36:00 UTC
[jira] [Resolved] (SPARK-35807) Rename the `num_files` argument
[ https://issues.apache.org/jira/browse/SPARK-35807?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Haejoon Lee resolved SPARK-35807.
---------------------------------
Resolution: Invalid
Seems like we need more discussion. Let me just close this for now.
> Rename the `num_files` argument
> -------------------------------
>
> Key: SPARK-35807
> URL: https://issues.apache.org/jira/browse/SPARK-35807
> Project: Spark
> Issue Type: Sub-task
> Components: PySpark
> Affects Versions: 3.2.0
> Reporter: Haejoon Lee
> Priority: Major
>
> We should rename the num_files argument in [DataFrame.to_csv |https://koalas.readthedocs.io/en/latest/reference/api/databricks.koalas.DataFrame.to_csv.html]and [DataFrame.to_json|https://koalas.readthedocs.io/en/latest/reference/api/databricks.koalas.DataFrame.to_json.html].
> Because the behavior of num_files is not actually specify the number of files, but it specifies the number of partition.
> Or we just can remove, and use the +[DataFrame.spark.repartition|https://koalas.readthedocs.io/en/latest/reference/api/databricks.koalas.DataFrame.spark.repartition.html]+ as a work around.
--
This message was sent by Atlassian Jira
(v8.3.4#803005)
---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org