You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@harmony.apache.org by "Jimmy, Jing Lv (JIRA)" <ji...@apache.org> on 2007/02/01 10:35:05 UTC

[jira] Created: (HARMONY-3106) [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony

[classlib][luni]add some cache ids to improve performance and rename JCL to Harmony
-----------------------------------------------------------------------------------

                 Key: HARMONY-3106
                 URL: https://issues.apache.org/jira/browse/HARMONY-3106
             Project: Harmony
          Issue Type: Improvement
          Components: Classlib
            Reporter: Jimmy, Jing Lv


As id-cache is enabled in luni, add some more reflect id cache may enhance performance.
And all "JCL" can be rename to "Harmony"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HARMONY-3106) [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony

Posted by "Jimmy, Jing Lv (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HARMONY-3106?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jimmy, Jing Lv updated HARMONY-3106:
------------------------------------

    Attachment:     (was: 3106.zip)

> [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony
> -----------------------------------------------------------------------------------
>
>                 Key: HARMONY-3106
>                 URL: https://issues.apache.org/jira/browse/HARMONY-3106
>             Project: Harmony
>          Issue Type: Improvement
>          Components: Classlib
>            Reporter: Jimmy, Jing Lv
>         Assigned To: Paulex Yang
>         Attachments: 3106.zip
>
>
> As id-cache is enabled in luni, add some more reflect id cache may enhance performance.
> And all "JCL" can be rename to "Harmony"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HARMONY-3106) [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony

Posted by "Jimmy, Jing Lv (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HARMONY-3106?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jimmy, Jing Lv updated HARMONY-3106:
------------------------------------

    Attachment: 3106.zip

Hi,
      Would you please try my patch? Thanks!
Best Regards,
Jimmy

> [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony
> -----------------------------------------------------------------------------------
>
>                 Key: HARMONY-3106
>                 URL: https://issues.apache.org/jira/browse/HARMONY-3106
>             Project: Harmony
>          Issue Type: Improvement
>          Components: Classlib
>            Reporter: Jimmy, Jing Lv
>         Attachments: 3106.zip
>
>
> As id-cache is enabled in luni, add some more reflect id cache may enhance performance.
> And all "JCL" can be rename to "Harmony"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (HARMONY-3106) [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony

Posted by "Paulex Yang (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HARMONY-3106?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Paulex Yang resolved HARMONY-3106.
----------------------------------

    Resolution: Fixed

Jimmy, patch applied at revision r503632, thanks a lot for this enhancement, please verify that the problem is fully fixed as you expected.

BTW, I prefered not to remove the old patch when you submit a new one, so that the history can be tracked, and on the other hand, sometimes I'm confused if the new patch has same name with the old one.


> [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony
> -----------------------------------------------------------------------------------
>
>                 Key: HARMONY-3106
>                 URL: https://issues.apache.org/jira/browse/HARMONY-3106
>             Project: Harmony
>          Issue Type: Improvement
>          Components: Classlib
>            Reporter: Jimmy, Jing Lv
>         Assigned To: Paulex Yang
>         Attachments: 3106.zip
>
>
> As id-cache is enabled in luni, add some more reflect id cache may enhance performance.
> And all "JCL" can be rename to "Harmony"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HARMONY-3106) [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony

Posted by "Paulex Yang (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HARMONY-3106?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12470126 ] 

Paulex Yang commented on HARMONY-3106:
--------------------------------------

Jimmy, I cannot compile the native codes after applying your patch, seems there are other files refer to jclglob.h, say, helpers.c, etc, would you please have a look? Thanks.

> [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony
> -----------------------------------------------------------------------------------
>
>                 Key: HARMONY-3106
>                 URL: https://issues.apache.org/jira/browse/HARMONY-3106
>             Project: Harmony
>          Issue Type: Improvement
>          Components: Classlib
>            Reporter: Jimmy, Jing Lv
>         Assigned To: Paulex Yang
>         Attachments: 3106.zip
>
>
> As id-cache is enabled in luni, add some more reflect id cache may enhance performance.
> And all "JCL" can be rename to "Harmony"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HARMONY-3106) [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony

Posted by "Jimmy, Jing Lv (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HARMONY-3106?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jimmy, Jing Lv updated HARMONY-3106:
------------------------------------

    Attachment:     (was: 3106.zip)

> [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony
> -----------------------------------------------------------------------------------
>
>                 Key: HARMONY-3106
>                 URL: https://issues.apache.org/jira/browse/HARMONY-3106
>             Project: Harmony
>          Issue Type: Improvement
>          Components: Classlib
>            Reporter: Jimmy, Jing Lv
>         Assigned To: Paulex Yang
>         Attachments: 3106.zip
>
>
> As id-cache is enabled in luni, add some more reflect id cache may enhance performance.
> And all "JCL" can be rename to "Harmony"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Assigned: (HARMONY-3106) [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony

Posted by "Paulex Yang (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HARMONY-3106?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Paulex Yang reassigned HARMONY-3106:
------------------------------------

    Assignee: Paulex Yang

> [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony
> -----------------------------------------------------------------------------------
>
>                 Key: HARMONY-3106
>                 URL: https://issues.apache.org/jira/browse/HARMONY-3106
>             Project: Harmony
>          Issue Type: Improvement
>          Components: Classlib
>            Reporter: Jimmy, Jing Lv
>         Assigned To: Paulex Yang
>         Attachments: 3106.zip
>
>
> As id-cache is enabled in luni, add some more reflect id cache may enhance performance.
> And all "JCL" can be rename to "Harmony"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HARMONY-3106) [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony

Posted by "Jimmy, Jing Lv (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HARMONY-3106?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jimmy, Jing Lv updated HARMONY-3106:
------------------------------------

    Attachment: 3106.zip

Hi Paulex,
      Would you please try this patch? Thanks!
Best Regards,
Jimmy

> [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony
> -----------------------------------------------------------------------------------
>
>                 Key: HARMONY-3106
>                 URL: https://issues.apache.org/jira/browse/HARMONY-3106
>             Project: Harmony
>          Issue Type: Improvement
>          Components: Classlib
>            Reporter: Jimmy, Jing Lv
>         Assigned To: Paulex Yang
>         Attachments: 3106.zip
>
>
> As id-cache is enabled in luni, add some more reflect id cache may enhance performance.
> And all "JCL" can be rename to "Harmony"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HARMONY-3106) [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony

Posted by "Jimmy, Jing Lv (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HARMONY-3106?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jimmy, Jing Lv updated HARMONY-3106:
------------------------------------

    Attachment: 3106.zip

> [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony
> -----------------------------------------------------------------------------------
>
>                 Key: HARMONY-3106
>                 URL: https://issues.apache.org/jira/browse/HARMONY-3106
>             Project: Harmony
>          Issue Type: Improvement
>          Components: Classlib
>            Reporter: Jimmy, Jing Lv
>         Attachments: 3106.zip
>
>
> As id-cache is enabled in luni, add some more reflect id cache may enhance performance.
> And all "JCL" can be rename to "Harmony"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HARMONY-3106) [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony

Posted by "Jimmy, Jing Lv (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HARMONY-3106?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jimmy, Jing Lv updated HARMONY-3106:
------------------------------------

    Attachment: 3106.zip

> [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony
> -----------------------------------------------------------------------------------
>
>                 Key: HARMONY-3106
>                 URL: https://issues.apache.org/jira/browse/HARMONY-3106
>             Project: Harmony
>          Issue Type: Improvement
>          Components: Classlib
>            Reporter: Jimmy, Jing Lv
>         Assigned To: Paulex Yang
>         Attachments: 3106.zip
>
>
> As id-cache is enabled in luni, add some more reflect id cache may enhance performance.
> And all "JCL" can be rename to "Harmony"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HARMONY-3106) [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony

Posted by "Jimmy, Jing Lv (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HARMONY-3106?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jimmy, Jing Lv updated HARMONY-3106:
------------------------------------

    Attachment:     (was: 3106.zip)

> [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony
> -----------------------------------------------------------------------------------
>
>                 Key: HARMONY-3106
>                 URL: https://issues.apache.org/jira/browse/HARMONY-3106
>             Project: Harmony
>          Issue Type: Improvement
>          Components: Classlib
>            Reporter: Jimmy, Jing Lv
>
> As id-cache is enabled in luni, add some more reflect id cache may enhance performance.
> And all "JCL" can be rename to "Harmony"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HARMONY-3106) [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony

Posted by "Jimmy, Jing Lv (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HARMONY-3106?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12470797 ] 

Jimmy, Jing Lv commented on HARMONY-3106:
-----------------------------------------

The fix is fine, thanks,Pualex. Yes, I'll remember this.

> [classlib][luni]add some cache ids to improve performance and rename JCL to Harmony
> -----------------------------------------------------------------------------------
>
>                 Key: HARMONY-3106
>                 URL: https://issues.apache.org/jira/browse/HARMONY-3106
>             Project: Harmony
>          Issue Type: Improvement
>          Components: Classlib
>            Reporter: Jimmy, Jing Lv
>         Assigned To: Paulex Yang
>         Attachments: 3106.zip
>
>
> As id-cache is enabled in luni, add some more reflect id cache may enhance performance.
> And all "JCL" can be rename to "Harmony"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.