You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@commons.apache.org by "Matt Juntunen (JIRA)" <ji...@apache.org> on 2018/12/15 21:00:01 UTC

[jira] [Created] (GEOMETRY-27) OrientedPoint API Cleanup

Matt Juntunen created GEOMETRY-27:
-------------------------------------

             Summary: OrientedPoint API Cleanup
                 Key: GEOMETRY-27
                 URL: https://issues.apache.org/jira/browse/GEOMETRY-27
             Project: Apache Commons Geometry
          Issue Type: Wish
            Reporter: Matt Juntunen


The following changes should be made to the {{OrientedPoint}} class:
- Replace {{direct}} boolean with {{direction}} {{Vector1D}} instance. The "direct" terminology is not clear to most users and having a vector to indicate the orientation of the point is much more intuitive and easier to work with.
- add {{equals}}, {{hashCode}}, and {{toString}}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)