You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Todd Lipcon (JIRA)" <ji...@apache.org> on 2011/05/05 03:27:03 UTC
[jira] [Updated] (HDFS-1799) Refactor log rolling and filename
management out of FSEditLog
[ https://issues.apache.org/jira/browse/HDFS-1799?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Todd Lipcon updated HDFS-1799:
------------------------------
Attachment: hdfs-1799-alternate-design.txt
Here's an implementation of the alternate design discussed above.
Basically, what this ended up being is the following:
- new inner class JournalAndStream in FSEditLog which keeps the journal next to its current stream
- instead of calling down to the JournalManager.getCurrentStream() for every operation, now we just use JournalAndStream.getCurrentStream(). This has the advantage that JournalManagers are more like straight factories.
This patch needs HDFS-1892 in order to pass unit tests, but I think it should compile OK without it.
It could also do with a little cleanup/javadoc additions.
Ivan, Eli, what do you think? Is this better? I actually still prefer the original patch, but if you think this is a big improvement we can move forward with this way.
> Refactor log rolling and filename management out of FSEditLog
> -------------------------------------------------------------
>
> Key: HDFS-1799
> URL: https://issues.apache.org/jira/browse/HDFS-1799
> Project: Hadoop HDFS
> Issue Type: Sub-task
> Affects Versions: Edit log branch (HDFS-1073)
> Reporter: Todd Lipcon
> Assignee: Todd Lipcon
> Fix For: Edit log branch (HDFS-1073)
>
> Attachments: 0001-Added-state-management-to-FSEditLog.patch, 0002-Standardised-error-pattern.patch, 0003-Add-JournalFactory-and-move-divert-revert-out-of-FSE.patch, HDFS-1799-all.diff, hdfs-1799-alternate-design.txt, hdfs-1799.txt, hdfs-1799.txt, hdfs-1799.txt, hdfs-1799.txt
>
>
> This is somewhat similar to HDFS-1580, but less ambitious. While that JIRA focuses on pluggability, this task is simply the minimum needed for HDFS-1073:
> - Refactor the filename-specific code for rolling, diverting, and reverting log streams out of FSEditLog into a new class
> - Clean up the related code in FSEditLog a bit
> Notably, this JIRA is going to temporarily break the BackupNode. I plan to circle back on the BackupNode later on this branch.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira