You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@tez.apache.org by "Bikas Saha (JIRA)" <ji...@apache.org> on 2014/08/06 22:30:14 UTC
[jira] [Commented] (TEZ-1231) Clean up TezRuntimeConfiguration
[ https://issues.apache.org/jira/browse/TEZ-1231?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14088207#comment-14088207 ]
Bikas Saha commented on TEZ-1231:
---------------------------------
There are some items in TezConfiguration like DagAppMaster name that should probably move to TezConstants.
> Clean up TezRuntimeConfiguration
> --------------------------------
>
> Key: TEZ-1231
> URL: https://issues.apache.org/jira/browse/TEZ-1231
> Project: Apache Tez
> Issue Type: Improvement
> Reporter: Siddharth Seth
> Priority: Blocker
>
> Separate configs used by runtime Inputs/Outputs and framework specific configs As an example - task memory configs are not related to any Input / Output. Similarly for Credentials.
> Other possible config changes
> - Rename TEZ_RUNTIME_INPUT_BUFFER_PERCENT, which is a fairly confusing name
> - Get rid of the separation between INPUT/OUTPU in config names (e.g. INPUT_KEY, OUTPUT_KEY replaced with just KEY)
> - Move TEZ_RUNTIME_INTERMEDIATE_INPUT_KEY_SECONDARY_COMPARATOR_CLASS to MapReduce
--
This message was sent by Atlassian JIRA
(v6.2#6252)