You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-issues@hadoop.apache.org by "Allen Wittenauer (JIRA)" <ji...@apache.org> on 2016/07/07 15:21:11 UTC

[jira] [Comment Edited] (HADOOP-13349) HADOOP_CLASSPATH vs HADOOP_USER_CLASSPATH

    [ https://issues.apache.org/jira/browse/HADOOP-13349?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15366239#comment-15366239 ] 

Allen Wittenauer edited comment on HADOOP-13349 at 7/7/16 3:20 PM:
-------------------------------------------------------------------

-00:
* change all instances of HADOOP\_USER\_CLASSPATH to HADOOP\_CLASSPATH

Hooray! Almost all of these are documentation changes.  The fact is, HADOOP\_USER\_CLASSPATH is a better name. But since Windows isn't changing, it just makes sense to go back to HADOOP\_CLASSPATH so that documentation is similar. If anyone thinks HADOOP\_USER\_CLASSPATH really is the way to go forward, it's no big deal to change it.  This patch becomes more of a code change than a documentation change, however.

It's worth pointing out even the unit tests were written to HADOOP\_CLASSPATH. :(


was (Author: aw):
-00:
* change all instances of HADOOP\_USER\_CLASSPATH to HADOOP\_CLASSPATH

Hooray! Almost all of these are documentation changes.  The fact is, HADOOP\_USER\_CLASSPATH is a better name. But since Windows isn't changing, it just makes sense to go back to HADOOP\_CLASSPATH so that documentation is similar. If anything thinks HADOOP\_USER\_CLASSPATH really is the way to go forward, it's no big deal to change it.  This patch becomes more of a code change than a documentation change, however.

It's worth pointing out even the unit tests were written to HADOOP\_CLASSPATH. :(

> HADOOP_CLASSPATH vs HADOOP_USER_CLASSPATH
> -----------------------------------------
>
>                 Key: HADOOP-13349
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13349
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: scripts
>    Affects Versions: 3.0.0-alpha1
>            Reporter: Allen Wittenauer
>            Assignee: Allen Wittenauer
>            Priority: Blocker
>         Attachments: HADOOP-13349.00.patch
>
>
> There seems to be some confusion in HADOOP_CLASSPATH vs. HADOOP_USER_CLASSPATH in the code and documentation, especially since HADOOP_USER_CLASSPATH doesn't appear to be wired up.  This needs to to get fixed ASAP.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org