You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@isis.apache.org by "ASF subversion and git services (JIRA)" <ji...@apache.org> on 2013/11/19 09:27:28 UTC

[jira] [Commented] (ISIS-594) Tidy up and simplify URLs in Wicket viewer.

    [ https://issues.apache.org/jira/browse/ISIS-594?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13826300#comment-13826300 ] 

ASF subversion and git services commented on ISIS-594:
------------------------------------------------------

Commit bbcb0bb1716118572d965c2c17c3390b6c0bf264 in branch refs/heads/master from [~danhaywood]
[ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=bbcb0bb ]

ISIS-594,ISIS-589: simplified URLs; method rename for CSS bundling

Specifically, for ISIS-594:
- IsisWicketApplication, mount pages using mount(...) method
- PageParameterNames, removed ACTION_MODE, PAGE_TITLE, PAGE_TYPE
- BookmarkableModel (as implemented by ActionModel and EntityModel)
  - extended to define getTitle() - since no longer in PageParameters
  - no longer caches page parameters, since caching of title done in subclasses
    - rename asPageParameters() to getPageParameters(), made abstract
- ActionModel now infers pageType, actionMode, pageTitle (caches title);
  also the page parameter's Oid when called in getPageParameters() - as used for bookmarks -
  no longer holds the version (there's no need for bookmarks);
  also creates with INLINE vs REDIRECT mode (since bookmarkable actions have safe action semantics)
- EntityModel now infers pageType, pageTitle
- BookmarkTreeNode refactored significantly:
  - holds bookmarkableModel as field rather than pageParameters
  - infers pageType from runtime type of provided BookmarkableModel
  - now caches title, updateable on matching as previously
  - does matching simply on pageParameters (was able to remove the hack
    whereby pageTitle in page parameters had to be temporarily removed,
    since that is no longer a parameter name at all)
- BookmarkTreeNodeComparator refactored a little:
  - order by pageType (as previously), then class name (for both actions as well as entities), then the title
- BookmarkedPagesModel simplified
  - removed isValidParameters() check, since those parameter names (page title, page type) have now gone
  - #titleFrom helper also removed, no longer called
- BookmarkedPagesPanel now gets page type and page title from the BookmarkedPagesModel,
  rather than the page parameters
- ActionLinkPanel, AppActionsCssMenuLinkFactory updated w.r.t getPageParameters() call etc
- PageAbstract constructor now takes a title, since no longer passed as a page parameter
  - EntityPage and ActionPage provide a title
  - remaining do not, defaults to application name

for ISIS-589:
- renamed ComponentFactory#getCssResourceReferences to #getCssResourceReference,
  because only ever returns a single object
  (in an earlier version of the impl, this method returned a list)
- removed CollectionContentsAsSummary from bundle, trying to get its CSS image url to work


> Tidy up and simplify URLs in Wicket viewer.
> -------------------------------------------
>
>                 Key: ISIS-594
>                 URL: https://issues.apache.org/jira/browse/ISIS-594
>             Project: Isis
>          Issue Type: Improvement
>          Components: Viewer: Wicket
>    Affects Versions: viewer-wicket-1.3.1
>            Reporter: Dan Haywood
>            Assignee: Dan Haywood
>            Priority: Minor
>             Fix For: viewer-wicket-1.4.0
>
>
> ... by mounting the pages, and using templated URLs for a cleaner look.
> Also remove info from pageParameters that can be inferred from existing information (pageType, pageTitle, actionMode).



--
This message was sent by Atlassian JIRA
(v6.1#6144)