You are viewing a plain text version of this content. The canonical link for it is here.
Posted to oak-issues@jackrabbit.apache.org by "Julian Reschke (Jira)" <ji...@apache.org> on 2024/12/15 11:41:00 UTC

[jira] [Created] (OAK-11312) Refactor CollectionUtils

Julian Reschke created OAK-11312:
------------------------------------

             Summary: Refactor CollectionUtils
                 Key: OAK-11312
                 URL: https://issues.apache.org/jira/browse/OAK-11312
             Project: Jackrabbit Oak
          Issue Type: Improvement
          Components: commons
            Reporter: Julian Reschke
            Assignee: Julian Reschke


While working on OAK-10685, it occured to that refactoring/splitting {{CollectionUtils}} might make the usage slightly more readable.

In particular:
 # Split {{CollectionUtils}} into classes for each collection type (List/Set/Map..)
 # Rename "{{toXxx(...)}}" to "{{from(...)}}"

For instance

{{CollectionUtils.toSet(xyz)}}

would become

{{SetUtils.from(xyz)}}

[~baedke] , [~daim] -wdyt?



--
This message was sent by Atlassian Jira
(v8.20.10#820010)