You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by Senthil Kumaran S <se...@collab.net> on 2007/12/11 09:26:12 UTC
[PATCH] Follow up to r27817
Hi,
I am attaching a patch along with this email in order to rename the
svndumpfilter option "--skip-missing-merge-sources" to "--skip-missing-merges"
as per Kamesh's comment here http://svn.haxx.se/dev/archive-2007-11/0726.shtml
[[[
Rename skip_missing_merge_sources option.
Follow up to r27817.
* subversion/svndumpfilter/main.c
(parse_baton_t): Rename skip_missing_merge_sources to skip_missing_merges
(adjust_mergeinfo): Reflect above change
(svn_opt_subcommand_t): Rename --skip-missing-merge-sources option to
--skip-missing-merges
(options_table): Reflect above changes in description
(cmd_table): Reflect above changes in description
(svndumpfilter_opt_state): Reflect above changes and fix the trailing
comments
(parse_baton_initialize): Reflect above changes
(main): Reflect above changes in switch case
* subversion/tests/cmdline/svndumpfilter_tests.py
(reflect_dropped_renumbered_revs): Change the option name from
--skip-missing-merge-sources to --skip-missing-merges
Patch by: stylesen
Suggested by: kameshj
]]]
Thank You.
PS: I shall post a separate patch for the other issue (revmap_start->dropped)
mentioned in Kamesh's comment.
--
Senthil Kumaran S
http://www.stylesen.org/
Re: [PATCH] Follow up to r27817
Posted by Kamesh Jayachandran <ka...@collab.net>.
Senthil,
Patch looks good.
In http://svn.haxx.se/dev/archive-2007-11/0726.shtml I raised this
concern along with renum issues.
Ideally this need to be committed along with renum fix or after that.
+1 to commit.
With regards
Kamesh Jayachandran
Senthil Kumaran S wrote:
> Hi,
>
> I am attaching a patch along with this email in order to rename the
> svndumpfilter option "--skip-missing-merge-sources" to
> "--skip-missing-merges" as per Kamesh's comment here
> http://svn.haxx.se/dev/archive-2007-11/0726.shtml
>
> [[[
> Rename skip_missing_merge_sources option.
>
> Follow up to r27817.
>
> * subversion/svndumpfilter/main.c
> (parse_baton_t): Rename skip_missing_merge_sources to
> skip_missing_merges
> (adjust_mergeinfo): Reflect above change
> (svn_opt_subcommand_t): Rename --skip-missing-merge-sources option to
> --skip-missing-merges
> (options_table): Reflect above changes in description
> (cmd_table): Reflect above changes in description
> (svndumpfilter_opt_state): Reflect above changes and fix the trailing
> comments
> (parse_baton_initialize): Reflect above changes
> (main): Reflect above changes in switch case
>
> * subversion/tests/cmdline/svndumpfilter_tests.py
> (reflect_dropped_renumbered_revs): Change the option name from
> --skip-missing-merge-sources to --skip-missing-merges
>
> Patch by: stylesen
> Suggested by: kameshj
> ]]]
>
> Thank You.
>
> PS: I shall post a separate patch for the other issue
> (revmap_start->dropped) mentioned in Kamesh's comment.
>
> --
> Senthil Kumaran S
> http://www.stylesen.org/
> ------------------------------------------------------------------------
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org