You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@commons.apache.org by Gary Gregory <gg...@seagullsoftware.com> on 2005/08/22 00:11:09 UTC
[lang] StrTokenizer.getCSVXxx and getTSVXxx method names.
Hello All:
I would prefer that the methods StrTokenizer.getCSVXxx and getTSVXxx
method be camel-cased like getCsvXxx and getTsvXxx. In general I prefer
to camel case acronyms to help readability when more than one acronym is
used, as in getIbmSoapXml() instead of getIBMSOAPXM().
Onions?
Thanks,
Gary
---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org
Re: [lang] StrTokenizer.getCSVXxx and getTSVXxx method names.
Posted by Steven Caswell <st...@gmail.com>.
I agree, I prefer this naming convention also.
On 8/21/05, Gary Gregory <gg...@seagullsoftware.com> wrote:
> Hello All:
>
> I would prefer that the methods StrTokenizer.getCSVXxx and getTSVXxx
> method be camel-cased like getCsvXxx and getTsvXxx. In general I prefer
> to camel case acronyms to help readability when more than one acronym is
> used, as in getIbmSoapXml() instead of getIBMSOAPXM().
>
> Onions?
>
> Thanks,
> Gary
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
>
>
--
Steven Caswell
steven.caswell@gmail.com
(c) 404-693-4148
(o) 404-260-2382
Take back the web - http://www.mozilla.org
---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org
Re: [lang] StrTokenizer.getCSVXxx and getTSVXxx method names.
Posted by Stephen Colebourne <sc...@btopenworld.com>.
--- Gary Gregory <gg...@seagullsoftware.com> wrote:
> I would prefer that the methods
> StrTokenizer.getCSVXxx and getTSVXxx
> method be camel-cased like getCsvXxx and getTsvXxx.
> In general I prefer
> to camel case acronyms to help readability when more
> than one acronym is
> used, as in getIbmSoapXml() instead of
> getIBMSOAPXM().
I personally prefer the current naming style, however,
I believe that prior art in [lang] means that these
should be changed. (ie. if you can find another
example in [lang] go ahead and make the change)
Stephen
---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org