You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@trafficserver.apache.org by "ASF subversion and git services (JIRA)" <ji...@apache.org> on 2016/05/02 04:18:13 UTC

[jira] [Commented] (TS-4364) Remove some remnants from http/2 refactoring

    [ https://issues.apache.org/jira/browse/TS-4364?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15266061#comment-15266061 ] 

ASF subversion and git services commented on TS-4364:
-----------------------------------------------------

Commit 377ffdc65978dd10344dd4a3bcef0677f8263a4e in trafficserver's branch refs/heads/6.2.x from shinrich
[ https://git-wip-us.apache.org/repos/asf?p=trafficserver.git;h=377ffdc ]

TS-4364: Address remnants from HTTP/2 refactoring.  This closes #584.

(cherry picked from commit 2a1c3996d1641bd246faf39a171b330ac33da34c)


> Remove some remnants from http/2 refactoring
> --------------------------------------------
>
>                 Key: TS-4364
>                 URL: https://issues.apache.org/jira/browse/TS-4364
>             Project: Traffic Server
>          Issue Type: Improvement
>          Components: HTTP/2
>            Reporter: Leif Hedstrom
>            Assignee: Susan Hinrichs
>              Labels: newbie++
>             Fix For: 6.2.0, 7.0.0
>
>
> It seems this code is no longer applicable, and we should remove it for clarity. It can wait until 7.0.0 though.
> {code}
> HttpTransact::handle_response_keep_alive_headers(State *s, HTTPVersion ver, HTTPHdr *heads)
> {
> .
> .
> .
>     // check that the client is HTTP 1.1 and the conf allows chunking
>     if (s->client_info.http_version == HTTPVersion(1, 1) &&
>         (s->txn_conf->chunking_enabled == 1 ||
>          (s->state_machine->plugin_tag &&
>           (!strcmp(s->state_machine->plugin_tag, "http/2") || !strncmp(s->state_machine->plugin_tag, "spdy", 4)))) &&
>         // if we're not sending a body, don't set a chunked header regardless of server response
>         !is_response_body_precluded(s->hdr_info.client_response.status_get(), s->method) &&
>         // we do not need chunked encoding for internal error messages
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)