You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@felix.apache.org by "Valentin Olteanu (JIRA)" <ji...@apache.org> on 2018/03/20 17:31:00 UTC

[jira] [Commented] (FELIX-5813) EventAdmin async threads should be named

    [ https://issues.apache.org/jira/browse/FELIX-5813?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16406742#comment-16406742 ] 

Valentin Olteanu commented on FELIX-5813:
-----------------------------------------

[~cziegeler], I've seen you handled FELIX-5006, so when you have time, could you please have a look here also?

> EventAdmin async threads should be named
> ----------------------------------------
>
>                 Key: FELIX-5813
>                 URL: https://issues.apache.org/jira/browse/FELIX-5813
>             Project: Felix
>          Issue Type: Bug
>          Components: Event Admin
>    Affects Versions: eventadmin-1.4.10
>            Reporter: Valentin Olteanu
>            Priority: Minor
>             Fix For: eventadmin-1.4.12
>
>
> Similar to FELIX-5006, the threads created in the async thread pools, should also be named. 
> The patch should be trivial:
> {code}
> diff --git a/eventadmin/impl/src/main/java/org/apache/felix/eventadmin/impl/tasks/DefaultThreadPool.java b/eventadmin/impl/src/main/java/org/apache/felix/eventadmin/impl/tasks/DefaultThreadPool.java
> index c582fdf47..b71f51bdc 100644
> --- a/eventadmin/impl/src/main/java/org/apache/felix/eventadmin/impl/tasks/DefaultThreadPool.java
> +++ b/eventadmin/impl/src/main/java/org/apache/felix/eventadmin/impl/tasks/DefaultThreadPool.java
> @@ -76,6 +76,7 @@ public class DefaultThreadPool
>                      thread.setPriority( Thread.NORM_PRIORITY );
>                      thread.setDaemon( true );
> +                    thread.setName("EventAdminAsyncThread #" + threadCounter.getAndIncrement());
>                      return thread;
>                  }
>              };
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)