You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@buildstream.apache.org by gi...@apache.org on 2020/12/29 13:10:06 UTC

[buildstream] branch bschubert/optimize-splits created (now 7151171)

This is an automated email from the ASF dual-hosted git repository.

github-bot pushed a change to branch bschubert/optimize-splits
in repository https://gitbox.apache.org/repos/asf/buildstream.git.


      at 7151171  element: Move __expand_splits to cython

This branch includes the following new commits:

     new 8e66edc  _yaml: Introduce a Scalar Node to encapsulate str/int/bools
     new 71b3ce6  _yaml: Introduce a 'Mapping' Node class
     new c826b4a  _yaml: Introduce a 'Sequence' Node
     new f68c766  _yaml: add 'get_mapping()' to MappingNode
     new 2f24719  _yaml: Add 'as_str()' on ScalarNode and 'get_scalar()' on MappingNode
     new 303fbde  _yaml: Add 'as_bool()' and 'is_none()' to ScalarNode
     new 3ce40d4  _yaml: Add 'as_int()' on ScalarNode
     new e4c538f  _yaml: Remove use of expected_type=None in 'node_get()'
     new e07d36a  _yaml: Introduce 'get_sequence()' and 'sequence_at()'/'mapping_at()'
     new 174079c  tests: remove 'node_get_yaml_provenance()' helper and replace with the new API
     new 9d48326  element: remove 'node_subst_list_element'
     new 6a57104  plugin: remove 'node_get_list_element'
     new 3ca9a72  element: Remove `node_get_member` and all references to it
     new d15f897  doc/bst2html: Remove usage of 'node_get' and use new API
     new 73d69e4  _yaml: Remove 'node_get' and migrate all remaining calls to new API
     new fe880da  _yaml: Never create base 'Node' directly
     new 64341ea  _yaml: Add a 'get_node' on Mapping, when return type can be of multiple types
     new 96dd4d5  _yaml: Remove 'node_copy' and add 'Node.copy()'
     new 03c2009  _yaml: Remove 'node_del' and support `del mapping[key]`
     new 54176df  _yaml: Remove 'node_keys' and add 'MappingNode.keys' to replace it
     new b735fcb  _yaml: Introduce 'MappingNode.values()'
     new 0805d33  _yaml: Remove 'node_items' and add 'MappingNode.items()'
     new 61e060b  _yaml: Remove 'node_set'. Now use __setitem__
     new e7c8d99  _yaml: Remove 'key' from node_find_target
     new 105be16  _yaml: Remove 'node_find_target' and replace by 'MappingNode.find'
     new f9933f7  _cachekey: Remove the 'node_sanitization' done before the json string
     new f855689  _yaml: Stop stringifying manually in roundtrip_dump
     new 5e50c6a  _yaml: Automatically represent Yaml nodes into yaml
     new 0c0867b  tests: Change all calls to _yaml.dump to _yaml.rountrip_dump
     new 52a8860  _yaml: Decomission 'dump()'. 'roundtrip_dump' is an equivalent function now
     new ee06f1b  _yaml: remove node_sanitize
     new 4936fc1  _yaml: Move 'node_final_assertions' to 'Node._assert_fully_composited'
     new eff4f45  tests/yaml: Stop using 'composite_dict' and use 'composite' instead
     new 39fe197  _yaml: move 'is_composite_list' as a Node member
     new e89adb8  _yaml: Move actual composition logic to MappingNode
     new 7953631  _yaml: Extract parts of 'composite_dict' to each type of 'Node'
     new 802c215  _yaml: move 'composite_dict' to 'MappingNode' as '_composite'
     new f78139e  _yaml: Move 'node_composite' to a method on 'MappingNode'
     new 3353457  _yaml: Add a 'from_dict' on Node to create new nodes from dicts
     new d9ece76  _yaml: Refer new synthetic nodes to their parents
     new f1c42cb  _yaml: Remove 'node_extend_list' and add 'SequenceNode.append'
     new b764dae  _yaml: Create 'from_dict' on Node and remove node creation methods
     new ee44d38  _yaml: Remove 'node_validate' and replace by 'MappingNode.validate_keys'
     new 03ba2cd  _yaml: Remove 'is_node', which is not used in the codebase anymore
     new 43d04ff  _yaml: Mark attributes on 'Node' as private (only c-accessible)
     new 48b9615  _yaml: Move 'value' of Node in each sub node
     new 72a8d76  _yaml: Use __cinit__ and __new__ to create node more effectively
     new aeb19e5  types: rework dependency to always get a 'Node' as dep and remove provenance
     new 5c48d10  _yaml: Remove 'indices' from 'node_get_provenance'
     new e9726b3  _project: remove 'key' argument from 'get_path_from_node'
     new 991519f  _yaml: rework 'assert_symbol_names' to not require provenance
     new 74c0968  _yaml: Remove 'node_get_provenance' and add 'Node.get_provenance'
     new 8ae5d1f  plugin: remove 'node_get_provenance', use the Node API directly
     new f13f913  _yaml: Remove code duplication on '_new_node_from_*'
     new 3c62b96  _yaml: Mark attributes in ProvenanceInformation as Buildstream-private
     new ae9c80e  _yaml: Move '__contains__' to MappingNode
     new 95d139a  _yaml: Set 'MappingNode' public-private API
     new 677cb39  _yaml: Mark new_syntethic_file as BuildStream private
     new 5a0cf52  _yaml: Mark 'strip_node_info' as buildstream-private
     new 0d8a8c7  Reorganize methods in Node classes
     new a467db3  _yaml: Split Node-related parts into 'node.pyx'
     new 38e705e  node: make 'assert_symbol_name' private
     new 6a6ef4e  node: Mark `MappingNode._get` as private
     new 1ebe452  node: Mark module-private functions and classes with '__'
     new 9f446dd  node: use 'pop' instead of 'del' for safe_del
     new 54e4f26  node: Rename 'copy' to 'clone'
     new a63a361  node: Make error messages more user-friendly
     new 337851c  node: document public API
     new eeede89  node: Document buildstream-private API and remove unused parameter
     new 0567c31  plugins: Update public documentation to be correct with the new Nodes
     new 58950e7  NEWS: update for new Node API
     new 57ab5dc  element: Rewrite 'dependencies()' to be more optimal
     new 4470414  element: optimize getting dependencies in cython
     new c5652e3  element: Add helper to get dependencies for a list of elements in a scope
     new 7151171  element: Move __expand_splits to cython

The 75 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.