You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@zookeeper.apache.org by "Benjamin Jaton (JIRA)" <ji...@apache.org> on 2016/08/18 23:45:20 UTC

[jira] [Updated] (ZOOKEEPER-2517) jute.maxbuffer is ignored

     [ https://issues.apache.org/jira/browse/ZOOKEEPER-2517?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Benjamin Jaton updated ZOOKEEPER-2517:
--------------------------------------
    Attachment: ZOOKEEPER-2517.patch

Proposed patch

> jute.maxbuffer is ignored
> -------------------------
>
>                 Key: ZOOKEEPER-2517
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-2517
>             Project: ZooKeeper
>          Issue Type: Bug
>    Affects Versions: 3.5.2
>            Reporter: Benjamin Jaton
>            Priority: Critical
>         Attachments: ZOOKEEPER-2517.patch
>
>
> In ClientCnxnSocket.java the parsing of the system property is erroneous:
> {code}packetLen = Integer.getInteger(
>   clientConfig.getProperty(ZKConfig.JUTE_MAXBUFFER),
>   ZKClientConfig.CLIENT_MAX_PACKET_LENGTH_DEFAULT
> );{code}
> Javadoc of Integer.getInteger states "The first argument is treated as the name of a system property", whereas here the value of the property is passed.
> Instead I believe the author meant to write something like:
> {code}packetLen = Integer.getInteger(
>   clientConfig.getProperty(
>     ZKConfig.JUTE_MAXBUFFER,
>     String.valueOf(ZKClientConfig.CLIENT_MAX_PACKET_LENGTH_DEFAULT)
>   )
> );{code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)