You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Erik Krogen (JIRA)" <ji...@apache.org> on 2017/08/01 19:15:00 UTC

[jira] [Commented] (HDFS-12143) Improve performance of getting and removing inode features

    [ https://issues.apache.org/jira/browse/HDFS-12143?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16109560#comment-16109560 ] 

Erik Krogen commented on HDFS-12143:
------------------------------------

Hey [~daryn], do you have any benchmark numbers to estimate how much performance increase the readability regression of foreach -> indexed brings? Finding a [source|https://aliteralmind.wordpress.com/2014/03/22/for_foreach/] which demonstrated the indexed form being faster than foreach was a little tough among many SO posts claiming they're equal. I'm curious if the benefits are amplified or diminished because of the small size of the array?

> Improve performance of getting and removing inode features
> ----------------------------------------------------------
>
>                 Key: HDFS-12143
>                 URL: https://issues.apache.org/jira/browse/HDFS-12143
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: namenode
>    Affects Versions: 2.8.0
>            Reporter: Daryn Sharp
>            Assignee: Daryn Sharp
>             Fix For: 2.9.0, 3.0.0-beta1, 2.8.3
>
>         Attachments: HDFS-12143.patch
>
>
> Getting a feature uses an iterator which is less performant than an indexed for loop.  Feature lookups are becoming more prolific so cycles count.
> Removing a feature requires building a string for up to 3 precondition checks.  The worst case of 3 is the penalty for a successful removal.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org