You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@avalon.apache.org by Jeremias Maerki <je...@outline.ch> on 2002/01/11 09:12:03 UTC

Logging in Avalon: CascadingThrowable and getTime/GetRTime in LogKit

I'm still not fully comfortable with the logging in Avalon. The reason
is that I can't get CascadingThrowables and the new getTime/getRTime
functionality to work at the same time. I'd like to change
org.apache.avalon.framework.AvalonFormatter, but before I do this, I'd
like to get your approval.

AvalonFormatter currently contains a method getTime() that masks the new
features recently introduced in LogKit CVS. I see two possibilities to
resolve this:
1. To maintain backwards compatibility I could snip out getStackTrace()
and create a parent class to AvalonFormatter (ex.
CascadingExPatternFormattern. Give me a better name if you have one!).
AvalonFormatter would then only contain a getTime() method.
2. If the current getTime() method is not so important, we could just
delete it. (I prefer that one)

On top of that I would like to change
org.apache.avalon.excalibur.logger.factory.FormatterFactory so it can
set a "depth" property (See ExceptionUtil) for the AvalonFormatter (or
its base class) to control the rendering of exceptions.

Thanks!

Cheers
Jeremias Märki

mailto:jeremias.maerki@outline.ch

OUTLINE AG
Postfach 3954 - Rhynauerstr. 15 - CH-6002 Luzern
Fon +41 (41) 317 2020 - Fax +41 (41) 317 2029
Internet http://www.outline.ch


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: Logging in Avalon: CascadingThrowable and getTime/GetRTime in LogKit

Posted by Peter Donald <pe...@apache.org>.
On Mon, 14 Jan 2002 18:57, Jeremias Maerki wrote:
> Hi Peter
>
> Thanks for taking it up. I've got a few more modifications to
> AvalonFormatter:
> - Made printing of nested exceptions configurable.
> - Completed javadocs.
> - Changed the constants to public, so they can be used by Excalibur's
>   FormatterFactory.
>
> Then, in the second diff, there are the modifications necessary to
> configure AvalonFormatter.

kool - could someone commit this? 

-- 
Cheers,

Pete

---------------------------------------------------
"Wise men don't need advice. Fools don't take it." 
                        -Benjamin Franklin 
---------------------------------------------------


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: Logging in Avalon: CascadingThrowable and getTime/GetRTime in LogKit

Posted by Jeremias Maerki <je...@outline.ch>.
Hi Peter

Thanks for taking it up. I've got a few more modifications to
AvalonFormatter:
- Made printing of nested exceptions configurable.
- Completed javadocs.
- Changed the constants to public, so they can be used by Excalibur's
  FormatterFactory.

Then, in the second diff, there are the modifications necessary to
configure AvalonFormatter.

On Sat, 12 Jan 2002 10:32:36 +1100 Peter Donald wrote:
> On Fri, 11 Jan 2002 19:12, Jeremias Maerki wrote:
> > 2. If the current getTime() method is not so important, we could just
> > delete it. (I prefer that one)
> 
> Hmm. I did this. I can't see why it was ever implemented. It had virtually 
> identical behaviour to the super classes behaviour ? Or am I missing 
> something.
> 
> > On top of that I would like to change
> > org.apache.avalon.excalibur.logger.factory.FormatterFactory so it can
> > set a "depth" property (See ExceptionUtil) for the AvalonFormatter (or
> > its base class) to control the rendering of exceptions.
> 
> I added support for this in AvalonFormatter. Awaiting patch for the 
> LogManager and friends ;)

Cheers,
Jeremias M�rki

mailto:jeremias.maerki@outline.ch

OUTLINE AG
Postfach 3954 - Rhynauerstr. 15 - CH-6002 Luzern
Fon +41 (41) 317 2020 - Fax +41 (41) 317 2029
Internet http://www.outline.ch

Re: Logging in Avalon: CascadingThrowable and getTime/GetRTime in LogKit

Posted by Berin Loritsch <bl...@apache.org>.
Peter Donald wrote:

> On Fri, 11 Jan 2002 19:12, Jeremias Maerki wrote:
> 
>>2. If the current getTime() method is not so important, we could just
>>delete it. (I prefer that one)
>>
> 
> Hmm. I did this. I can't see why it was ever implemented. It had virtually 
> identical behaviour to the super classes behaviour ? Or am I missing 
> something.


I never got around to having it format the date to a human readable form....
The skeleton was there--but that change got lost.




-- 

"They that give up essential liberty to obtain a little temporary safety
  deserve neither liberty nor safety."
                 - Benjamin Franklin


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: Logging in Avalon: CascadingThrowable and getTime/GetRTime in LogKit

Posted by Peter Donald <pe...@apache.org>.
On Fri, 11 Jan 2002 19:12, Jeremias Maerki wrote:
> 2. If the current getTime() method is not so important, we could just
> delete it. (I prefer that one)

Hmm. I did this. I can't see why it was ever implemented. It had virtually 
identical behaviour to the super classes behaviour ? Or am I missing 
something.

> On top of that I would like to change
> org.apache.avalon.excalibur.logger.factory.FormatterFactory so it can
> set a "depth" property (See ExceptionUtil) for the AvalonFormatter (or
> its base class) to control the rendering of exceptions.

I added support for this in AvalonFormatter. Awaiting patch for the 
LogManager and friends ;)

-- 
Cheers,

Pete

Frank Zappa observed: "It's not getting any smarter out
                       there.You have to come to terms with
                       stupidity, and make it work for you."

--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>