You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@directory.apache.org by co...@apache.org on 2024/08/14 12:49:04 UTC

(directory-kerby) branch trunk updated: Updating README

This is an automated email from the ASF dual-hosted git repository.

coheigea pushed a commit to branch trunk
in repository https://gitbox.apache.org/repos/asf/directory-kerby.git


The following commit(s) were added to refs/heads/trunk by this push:
     new e95fc06c Updating README
e95fc06c is described below

commit e95fc06cb22dce4ffca48d3be18583a86cbcb838
Author: Colm O hEigeartaigh <co...@apache.org>
AuthorDate: Wed Aug 14 13:48:53 2024 +0100

    Updating README
---
 README.md | 150 +-------------------------------------------------------------
 1 file changed, 2 insertions(+), 148 deletions(-)

diff --git a/README.md b/README.md
index 20ab18a5..01803a3d 100644
--- a/README.md
+++ b/README.md
@@ -173,7 +173,7 @@ The Apache Kerby is also available as a Maven dependency.
 </dependency>
 ```
 - please replace the ${kerby-version} with the release version.
-- Apache Kerby 1.0.1 is the latest release and recommended version for all users.
+- Apache Kerby 2.1.0 is the latest release and recommended version for all users.
 
 ### License
 Apache License V2.0
@@ -185,150 +185,4 @@ Apache License V2.0
 - Kerby Developers List: kerby@directory.apache.org [Subscribe](kerby-subscribe@directory.apache.org)
 
 ### Downloads
-- [Release 1.1.1](https://directory.apache.org/kerby/download/download-sources.html)
-
-### News
-- May 2018, Apache Kerby 1.1.1 is released.
-- November 2017, Apache Kerby 1.1.0 is released.
-- September 4th 2017, Apache Kerby 1.0.1 is released.
-- May 13th 2017, Apache Kerby 1.0.0 is released.
-- March 14th 2016, Apache Kerby 1.0.0-RC2 is released.
-- Sep 23 2015, the first release 1.0.0-RC1 of Kerby was released.
-
-### Apache Kerby 1.1.0 Release Notes
-
-Sub-task
-
-    [DIRKRB-123] - Implementing cross-realm support
-    [DIRKRB-551] - Data type conversion between GSSAPI interface and Kerby
-    [DIRKRB-555] - Implement GSSNameSpi interface
-    [DIRKRB-559] - Validataion of ApReq and ApRep message in peer node
-    [DIRKRB-560] - Implement GSSContextSpi interface
-    [DIRKRB-565] - Implement Gss tokens defined in RFC 4121
-    [DIRKRB-566] - Implement Gss tokens defined in RFC 1964
-    [DIRKRB-568] - Using RFC 4121 tokens in KerbyContext
-    [DIRKRB-571] - Add encryptRaw interface for GssToken encryption
-    [DIRKRB-576] - Add test for client-server based on Kerby GssApi
-    [DIRKRB-581] - Imcompatible token header in init context against JDK GssApi
-
-Bug
-
-    [DIRKRB-520] - Fix findbugs issuse in Kerby ASN1, Kerby Config and Kerby PKIX
-    [DIRKRB-636] - NPE in GssInitCred when no initial GSSCredential is passed to manager.createContext
-    [DIRKRB-637] - NPE in GssAcceptCred when no initial GSSCredential is passed to manager.createContext
-    [DIRKRB-638] - KerbyGssAppTest fails when there is no keytab on the service side
-    [DIRKRB-642] - Remove the bytes util functions in GssTokenBase
-    [DIRKRB-647] - Compilation error with java7 in gss module
-    [DIRKRB-652] - Support dynamic load token provider
-    [DIRKRB-656] - Compatibility problem with Kerberos when getting service ticket
-    [DIRKRB-658] - KerbyTokenAppTest failed on Mac
-    [DIRKRB-660] - Compatibility problem with hadoop when getting default credential cache
-    [DIRKRB-664] - Upgrade Nimbus dependency
-    [DIRKRB-666] - NPE if klist.sh is called on an empty cache
-    [DIRKRB-667] - Kerby and Tool distributions are lacking required jars
-    [DIRKRB-670] - Add checksum verification in TgsRequest
-
-Improvement
-
-    [DIRKRB-651] - Add support to send a JWT AccessToken via the GSS API
-    [DIRKRB-653] - Implement kinit -c -S to get service ticket
-    [DIRKRB-657] - Implement kinit tool to get tgt ticket from remote realm
-    [DIRKRB-661] - Add duration time parse support when parsing krb5.conf
-    [DIRKRB-668] - Enable KDC backend connect to the HA Zookeeper Cluster
-    [DIRKRB-669] - Authorization data needed by backend code create a circular project reference
-
-New Feature
-
-    [DIRKRB-535] - Implementing GSSAPI module based on Kerby Kerberos library
-    [DIRKRB-649] - Cross realm server side implementation
-
-Task
-
-    [DIRKRB-654] - Add support to receive a JWT AccessToken via the GSS API
-    [DIRKRB-655] - Add setting up cross realm authentication guide
-
-Test
-
-    [DIRKRB-663] - Add some unit tests for cross realm
-
-
-### Apache Kerby 1.0.1 Release Notes
-
-Bug
-
-    [DIRKRB-614] - Kerby (simplekdc) fails to handle unknown PADATA
-    [DIRKRB-629] - ICMP Port Unreachable error message with GSS + default transport
-    [DIRKRB-631] - Not compatible with MIT Kerberos 1.11+
-    [DIRKRB-633] - "Invalid signature file digest for Manifest main attributes" exception after running kinit tool
-    [DIRKRB-634] - Failed to get service granting ticket from MIT KDC using Kerby client
-    [DIRKRB-644] - ClassCastException in TokenPreauth
-    [DIRKRB-645] - Start KerbyKdcServer should be failed if kdc_port already in use
-
-Improvement
-
-    [DIRKRB-635] - Backends should be optional when building kerby
-    [DIRKRB-641] - Implement kinit -k -i
-    [DIRKRB-643] - Implement kinit -l -r
-    [DIRKRB-646] - Add the feature of parsing time duration for kinit tool
-
-New Feature
-
-    [DIRKRB-632] - Put claims from the JWT access token into the authorization data of the ticket
-
-
-### Apache Kerby 1.0.0 Release Notes
-
-Sub-task
-
-    [DIRKRB-247] - Kerby's KDC supports MIT's kinit
-    [DIRKRB-421] - Define transaction API for identity backend
-    [DIRKRB-422] - Enhance json backend to support transaction for reasonable efficiency
-    [DIRKRB-478] - Refine and enhance the client side library
-    [DIRKRB-524] - XDR (RFC 4506) support
-
-Bug
-
-    [DIRKRB-583] - Validate payload length declared in keytab
-    [DIRKRB-584] - NPE if the token issuers value is not specified
-    [DIRKRB-585] - Allow for optional expiry + NotBefore claims when processing a JWT token
-    [DIRKRB-586] - NPE in KdcHandler on an Exception
-    [DIRKRB-613] - Tests fails on systems with includedir in /etc/krb5.conf
-    [DIRKRB-621] - 0x502 version keytab with multiple entries are not read properly
-    [DIRKRB-624] - KdcServerTest failed with exception
-    [DIRKRB-626] - Some improvement work for exception handling
-    [DIRKRB-627] - Kerby hangs when the service principal is not known
-
-Improvement
-
-    [DIRKRB-416] - Allow to support transaction for backend
-    [DIRKRB-459] - Enhance the support for MIT krb5.conf configuration format
-    [DIRKRB-482] - Break down KrbOption
-    [DIRKRB-587] - Load JWT verification key from classpath as well
-    [DIRKRB-588] - Support validation keys in different formats
-    [DIRKRB-607] - Improve Simple KDC Server to be thread safe
-    [DIRKRB-623] - Move the backend releated tests to backend modules
-
-Task
-
-    [DIRKRB-155] - Add the missing Javadoc for kerby-asn1 module
-    [DIRKRB-532] - Encode and decode XDR: Union and Struct
-
-### Apache Kerby 1.0.0-RC2 Release Notes
-
-105 JIRA issues were resolved and with the following Features and important changes since 1.0.0-RC1:
-- 1. Anonymous PKINIT support(BETA): allows a client to obtain anonymous credentials without authenticating as any particular principal.
-- 2. Finished token support:
-  - Add ability to encrypt and sign using non-RSA keys;
-  - Get the verify key for signed JWT token from kdc config;
-  - Token issuer must be trusted as one of preconfigured issuers;
-  - Add support for decrypting JWT tokens in the KDC.
-- 3. PKIX CMS/X509 support.
-- 4. BER encoding support.
-- 5. Improved the ASN1 framework:
-  - Separate Asn1 parser;
-  - Support decoding of primitive but constructed encoded types;
-  - Allow to define explicit and implicit fields more easily for collection types;
-  - Providing an API to use some useful ASN1 functions by consolidating existing utilities
-- 6. Dump support for Asn1.
-  - provide an ASN1 dumping tool for troubleshooting
-- 7. Separate KrbClient, KrbTokenClient, and KrbPkinitClient APIs.
+- [Release 2.1.0](https://directory.apache.org/kerby/download/download-sources.html)