You are viewing a plain text version of this content. The canonical link for it is here.
Posted to jira@kafka.apache.org by "Omnia Ibrahim (Jira)" <ji...@apache.org> on 2024/06/07 09:22:00 UTC

[jira] [Comment Edited] (KAFKA-16638) Align the naming convention for config and default variables in *Config classes

    [ https://issues.apache.org/jira/browse/KAFKA-16638?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17853083#comment-17853083 ] 

Omnia Ibrahim edited comment on KAFKA-16638 at 6/7/24 9:21 AM:
---------------------------------------------------------------

Hi [~ericlu95] Yeah I wanted to update this Jira to remove the public apis from it but totally forgot. I think it would be hard to change the public ones This why I kept it open for discussions. Especially that they are used by App so this will be a very distributive change to do. It would be nice but unfornatly we can't change these anymore! 


was (Author: omnia_h_ibrahim):
Hi [~ericlu95] Yeah I wanted to update this Jira to remove the public apis from it but totally forgot. I think it would be hard to change the public ones as they are used by App so this will be a very distributive change to do. It would be nice but unfornatly we can't change these anymore!

> Align the naming convention for config and default variables in *Config classes
> -------------------------------------------------------------------------------
>
>                 Key: KAFKA-16638
>                 URL: https://issues.apache.org/jira/browse/KAFKA-16638
>             Project: Kafka
>          Issue Type: Task
>            Reporter: Omnia Ibrahim
>            Priority: Trivial
>
> Some classes in the code is violating the naming naming convention for config, doc, and default variables which is:
>  * `_CONFIG` suffix for defining the configuration
>  * `_DEFAULT` suffix for default value 
>  * `_DOC` suffix for doc
> The following classes need to be updated 
>  * `CleanerConfig` and `RemoteLogManagerConfig` to use  `_CONFIG` suffix instead of `_PROP`.
>  * Others like `LogConfig` and `QuorumConfig` to use `_DEFAULT` suffix instead of `DEFAULT_` prefix .
>  * same goes with `CommonClientConfigs`, `StreamsConfig` however these are public interfaces and will need a KIP to rename the default value variables and mark the old one as deprecated. This might need to be broken to different Jira.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)