You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hc.apache.org by ol...@apache.org on 2026/10/10 20:11:16 UTC
(httpcomponents-core) branch master updated (96623fbbe -> c5c6dd6cb)
This is an automated email from the ASF dual-hosted git repository.
ok2c pushed a change to branch master
in repository https://gitbox.apache.org/repos/asf/httpcomponents-core.git
discard 96623fbbe Correct typos in RELEASE_NOTES.txt
discard 792d4f5d3 Updated release notes for HttpCore 5.5-beta4 release
new 34412fb1d Updated release notes for HttpCore 5.5-beta4 release
new c5c6dd6cb Added RFC 9530 to the list of supported specifications
This update added new revisions after undoing existing revisions.
That is to say, some revisions that were in the old version of the
branch are not in the new version. This situation occurs
when a user --force pushes a change and generates a repository
containing something like this:
* -- * -- B -- O -- O -- O (96623fbbe)
\
N -- N -- N refs/heads/master (c5c6dd6cb)
You should already have received notification emails for all of the O
revisions, and so the following emails describe only the N revisions
from the common base, B.
Any revisions marked "omit" are not gone; other references still
refer to them. Any revisions marked "discard" are gone forever.
The 2 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails. The revisions
listed as "add" were already present in the repository and have only
been added to this reference.
Summary of changes:
README.md | 1 +
1 file changed, 1 insertion(+)
(httpcomponents-core) 01/02: Updated release notes for HttpCore 5.5-beta4 release
Posted by ol...@apache.org.
This is an automated email from the ASF dual-hosted git repository.
ok2c pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/httpcomponents-core.git
commit 34412fb1d04dec37e908afc7aeef7af66618cf5a
Author: Oleg Kalnichevski <ol...@apache.org>
AuthorDate: Sat Oct 10 14:26:08 2026 +0200
Updated release notes for HttpCore 5.5-beta4 release
---
RELEASE_NOTES.txt | 107 ++++++++++++++++++++++++++++++++++++++++++++++++++++--
1 file changed, 103 insertions(+), 4 deletions(-)
diff --git a/RELEASE_NOTES.txt b/RELEASE_NOTES.txt
index 05780541a..f05b3422f 100644
--- a/RELEASE_NOTES.txt
+++ b/RELEASE_NOTES.txt
@@ -1,12 +1,15 @@
-Release 5.5-beta3
+Release 5.5-beta4
-----------------
-This BETA release migrates JSON bindings to Jackson 3, introduces support for
-Structured Field Values (RFC 9651), and improves and optimizes message parsing
-support methods. It is expected to be the last BETA release before 5.5 GA.
+This BETA release features multiple HTTP/2 protocol conformance improvements
+and perfroance optimizations, introduces support for Digest Fields (RFC 9530),
+and improves async IOsession pool functionality.
+
+It is expected to be the last BETA release before 5.5 GA.
This release includes all fixes from the stable 5.4 branch.
+
Notable changes and features included in the 5.5 series:
* Improved connection pool implementation.
@@ -26,6 +29,11 @@ Notable changes and features included in the 5.5 series:
* Added support for Structured Field Values for HTTP (RFC 9651).
+* Added support for Digest Fields (RFC 9530).
+
+* Improved async IOSession pool implementation.
+
+
Compatibility notes:
* HTTP requesters and servers respect SSL/TLS system properties by default.
@@ -34,6 +42,97 @@ Compatibility notes:
artifacts remain compatible with Java 8.
+Change Log
+-------------------
+
+* Async sessions to update lastEventTime upon command submission.
+ Contributed by Oleg Kalnichevski <olegk at apache.org>
+
+* Async IOSession pool: improved available sessions enumeration, improved session
+ validation, and added method to evict expired sessions.
+ Contributed by Oleg Kalnichevski <olegk at apache.org>
+
+* Async IOSession sessions to capture the initiation time.
+ Contributed by Oleg Kalnichevski <olegk at apache.org>
+
+* Correct handling of unsigned HTTP/2 SETTINGS values.
+ Contributed by Arturo Bernal <abernal at apache.org>
+
+* Async IOSession pool: improved handling of idle sessions.
+ Contributed by Oleg Kalnichevski <olegk at apache.org>
+
+* Restore absolute millisecond timestamps in I/O reactor and H2.
+ Contributed by Arturo Bernal <abernal at apache.org>
+
+* AbstractHttp1StreamDuplexer should not trigger output interest when
+ completion of a message leaves no data in the output buffer.
+ Contributed by Oleg Kalnichevski <olegk at apache.org>
+
+* Complete I/O reactor termination when the selector has been closed by another thread.
+ Contributed by AdzerKI <silver_cat at list.ru>
+
+* HTTP/2: Stricter handling of responses carrying END_STREAM and response trailers without
+ END_STREAM.
+ Contributed by Arturo Bernal <abernal at apache.org>
+
+* HTTP/2: Stricter handling of pushed response message.
+ Contributed by Arturo Bernal <abernal at apache.org>
+
+* HTTP/2: Corrected handling of unprocessed local streams on GOAWAY signal.
+ Contributed by Ariel Rodriguez <ariel.rodriguez at recargapay.com>
+
+* Send RST_STREAM for a cancelled half-closed stream
+ Contributed by Ariel Rodriguez <ariel.rodriguez at recargapay.com>
+
+* HTTP/2: Corrected handling of H2 stream flow control overflow.
+ Contributed by Arturo Bernal <abernal at apache.org>
+
+* HTTP/2: Reject H2 DATA on reserved streams.
+ Contributed by Arturo Bernal <abernal at apache.org>
+
+* Optimizeed message list traversal in HTTP messages.
+ Contributed by Arturo Bernal <abernal at apache.org>
+
+* Added #isIdle method to async HTTP/1.1 and HTTP/2 protocol handlers to test if
+ there are ongoing messages exchanges.
+ Contributed by Oleg Kalnichevski <olegk at apache.org>
+
+* Improved endpoint release logic in HttpAsyncRequester.
+ Contributed by Oleg Kalnichevski <olegk at apache.org>
+
+* HTTP/2: Optimized HPACK full match lookup.
+ Contributed by Arturo Bernal <abernal at apache.org>
+
+* HTTP/2: Limit HPACK encoder table size.
+ Contributed by Arturo Bernal <abernal at apache.org>
+
+* Fixed defect in HPACK encoder buffer expansion for multibyte values.
+ Contributed by Arturo Bernal <abernal at apache.org>
+
+* Added H2MultiplexingRequester method to evict expired connections.
+ Contributed by Oleg Kalnichevski <olegk at apache.org>
+
+* HTTP/2: Improved HPACK decoding conformance.
+ Contributed by Arturo Bernal <abernal at apache.org>
+
+* HTTP/2: Optimized HPACK Huffman decoding with a byte-oriented DFA.
+ Contributed by Arturo Bernal <abernal at apache.org>
+
+* RFC 9530 Digest Fields support.
+ Contributed by Arturo Bernal <abernal at apache.org>
+
+* Limit write chunk size in async IOSession.
+ Contributed by yhzdys <yhzdys at foxmail.com>
+
+
+Release 5.5-beta3
+-----------------
+
+This BETA release migrates JSON bindings to Jackson 3, introduces support for
+Structured Field Values (RFC 9651), and improves and optimizes message parsing
+support methods. It is expected to be the last BETA release before 5.5 GA.
+
+
Change Log
-------------------
(httpcomponents-core) 02/02: Added RFC 9530 to the list of supported specifications
Posted by ol...@apache.org.
This is an automated email from the ASF dual-hosted git repository.
ok2c pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/httpcomponents-core.git
commit c5c6dd6cb39ae3f2f68519591a12983877ab959f
Author: Oleg Kalnichevski <ol...@apache.org>
AuthorDate: Sat Oct 10 22:11:03 2026 +0200
Added RFC 9530 to the list of supported specifications
---
README.md | 1 +
1 file changed, 1 insertion(+)
diff --git a/README.md b/README.md
index f7dc528ba..b4afe8a7b 100644
--- a/README.md
+++ b/README.md
@@ -48,6 +48,7 @@ Protocol conformance
- [RFC 9218](https://datatracker.ietf.org/doc/html/rfc9218) - Extensible Prioritization Scheme for HTTP
- [RFC 10008](https://datatracker.ietf.org/doc/html/rfc10008) - The HTTP QUERY Method
- [RFC 9651](https://datatracker.ietf.org/doc/html/rfc9651) - Structured Field Values for HTTP
+- [RFC 9530](https://datatracker.ietf.org/doc/html/rfc9530) - Digest Fields
Licensing