You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@pivot.apache.org by "Roger Whitcomb (JIRA)" <ji...@apache.org> on 2013/09/14 12:29:51 UTC

[jira] [Commented] (PIVOT-922) Some renderers were not calling their "toString" methods in the "render" methods

    [ https://issues.apache.org/jira/browse/PIVOT-922?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13767438#comment-13767438 ] 

Roger Whitcomb commented on PIVOT-922:
--------------------------------------

Fixed a number of the renderers in trunk:
Sending        wtk\src\org\apache\pivot\wtk\content\ButtonDataRenderer.java
Sending        wtk\src\org\apache\pivot\wtk\content\LinkButtonDataRenderer.java
Sending        wtk\src\org\apache\pivot\wtk\content\ListViewItemRenderer.java
Sending        wtk\src\org\apache\pivot\wtk\content\MenuBarItemDataRenderer.java
Sending        wtk\src\org\apache\pivot\wtk\content\MenuItemDataRenderer.java
Sending        wtk\src\org\apache\pivot\wtk\content\SpinnerItemRenderer.java
Sending        wtk\src\org\apache\pivot\wtk\content\TreeViewNodeRenderer.java
Transmitting file data .......
Committed revision 1523205.

Still need to check all the rest to make sure they are alright, and then cross to "branches/2.0.x" for 2.0.4.
                
> Some renderers were not calling their "toString" methods in the "render" methods
> --------------------------------------------------------------------------------
>
>                 Key: PIVOT-922
>                 URL: https://issues.apache.org/jira/browse/PIVOT-922
>             Project: Pivot
>          Issue Type: Bug
>          Components: wtk
>    Affects Versions: 2.0.3
>         Environment: All
>            Reporter: Roger Whitcomb
>            Assignee: Roger Whitcomb
>            Priority: Minor
>              Labels: renderer, wtk
>             Fix For: 2.0.4, 2.1
>
>
> Most Renderer instances have the required "render" method and also a "toString" method.  Since "render" can be complicated it is tempting to create a subclass and just change the "toString" method to do something special with the text (like using something besides "Object.toString()" to get the proper text).  But, many of the renderers don't call the "toString(Object)" method from "render", but instead duplicate the logic in there.  This renders the subclass approach ineffective.  And there is no particular reason for having the "toString" method except for it to be used in "render".

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira