You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@beam.apache.org by bakey pan <ba...@gmail.com> on 2016/02/18 16:41:56 UTC

Confusing about the bouded naming of PubsubIO

Hi,all:
    I notice that in in the PubSubIO class, there only exist one Bound
static class inherit from PTransform.
    But actually in the apply method of Bound,whether return a bounded or
unbounded PCollection is depend on the variables maxNumRecords and
maxReadTime.So why not name this class "MixBound" or else.
     I think that is a little bit confuse name it  "Bound" but actually it
can be unbouned data stream

-- 
 Best Regards
   BakeyPan

Re: Confusing about the bouded naming of PubsubIO

Posted by Kostas Kloudas <k....@data-artisans.com>.
Hi,

I agree that the distinction between Bound/Unbound, Bounded/Unbounded is not documented, 
and it is not trivial to get, even after looking at the code.

I think that even after renaming, a document or the javadocs should reflect 
naming conventions like this.

Cheers,
Kostas

> On Feb 18, 2016, at 8:46 PM, Jean-Baptiste Onofré <jb...@nanthrax.net> wrote:
> 
> Hi guys,
> 
> I used the same approach in the JMS IO, but I will rename according to Dan's comment.
> 
> Thanks,
> Regards
> JB
> 
> On 02/18/2016 05:37 PM, Dan Halperin wrote:
>> What Ben said is true .... but I'd be in favor of renaming or removing
>> these constructs once we can make backwards-incompatible changes ;)
>> 
>> On Thu, Feb 18, 2016 at 8:31 AM, Ben Chambers <bc...@google.com.invalid>
>> wrote:
>> 
>>> Classes named "Bound" are used throughout the sdk to describe builders that
>>> are specified enough to be applied. It indicates that the required
>>> parameters have been bound. It is not related to whether the output
>>> PCollection is bounded or unbounded.
>>> 
>>> On Thu, Feb 18, 2016, 7:42 AM bakey pan <ba...@gmail.com> wrote:
>>> 
>>>> Hi,all:
>>>>     I notice that in in the PubSubIO class, there only exist one Bound
>>>> static class inherit from PTransform.
>>>>     But actually in the apply method of Bound,whether return a bounded or
>>>> unbounded PCollection is depend on the variables maxNumRecords and
>>>> maxReadTime.So why not name this class "MixBound" or else.
>>>>      I think that is a little bit confuse name it  "Bound" but actually
>>> it
>>>> can be unbouned data stream
>>>> 
>>>> --
>>>>  Best Regards
>>>>    BakeyPan
>>>> 
>>> 
>> 
> 
> -- 
> Jean-Baptiste Onofré
> jbonofre@apache.org
> http://blog.nanthrax.net
> Talend - http://www.talend.com


Re: Confusing about the bouded naming of PubsubIO

Posted by Jean-Baptiste Onofré <jb...@nanthrax.net>.
Hi guys,

I used the same approach in the JMS IO, but I will rename according to 
Dan's comment.

Thanks,
Regards
JB

On 02/18/2016 05:37 PM, Dan Halperin wrote:
> What Ben said is true .... but I'd be in favor of renaming or removing
> these constructs once we can make backwards-incompatible changes ;)
>
> On Thu, Feb 18, 2016 at 8:31 AM, Ben Chambers <bc...@google.com.invalid>
> wrote:
>
>> Classes named "Bound" are used throughout the sdk to describe builders that
>> are specified enough to be applied. It indicates that the required
>> parameters have been bound. It is not related to whether the output
>> PCollection is bounded or unbounded.
>>
>> On Thu, Feb 18, 2016, 7:42 AM bakey pan <ba...@gmail.com> wrote:
>>
>>> Hi,all:
>>>      I notice that in in the PubSubIO class, there only exist one Bound
>>> static class inherit from PTransform.
>>>      But actually in the apply method of Bound,whether return a bounded or
>>> unbounded PCollection is depend on the variables maxNumRecords and
>>> maxReadTime.So why not name this class "MixBound" or else.
>>>       I think that is a little bit confuse name it  "Bound" but actually
>> it
>>> can be unbouned data stream
>>>
>>> --
>>>   Best Regards
>>>     BakeyPan
>>>
>>
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Re: Confusing about the bouded naming of PubsubIO

Posted by Robert Bradshaw <ro...@google.com.INVALID>.
+1, maybe call them "typed." (And for many transforms, the unbound versions
need not exist, so we wouldn't even need the distinction...)
On Feb 18, 2016 8:38 AM, "Dan Halperin" <dh...@google.com.invalid> wrote:

> What Ben said is true .... but I'd be in favor of renaming or removing
> these constructs once we can make backwards-incompatible changes ;)
>
> On Thu, Feb 18, 2016 at 8:31 AM, Ben Chambers <bchambers@google.com.invalid
> >
> wrote:
>
> > Classes named "Bound" are used throughout the sdk to describe builders
> that
> > are specified enough to be applied. It indicates that the required
> > parameters have been bound. It is not related to whether the output
> > PCollection is bounded or unbounded.
> >
> > On Thu, Feb 18, 2016, 7:42 AM bakey pan <ba...@gmail.com> wrote:
> >
> > > Hi,all:
> > >     I notice that in in the PubSubIO class, there only exist one Bound
> > > static class inherit from PTransform.
> > >     But actually in the apply method of Bound,whether return a bounded
> or
> > > unbounded PCollection is depend on the variables maxNumRecords and
> > > maxReadTime.So why not name this class "MixBound" or else.
> > >      I think that is a little bit confuse name it  "Bound" but actually
> > it
> > > can be unbouned data stream
> > >
> > > --
> > >  Best Regards
> > >    BakeyPan
> > >
> >
>

Re: Confusing about the bouded naming of PubsubIO

Posted by Dan Halperin <dh...@google.com.INVALID>.
What Ben said is true .... but I'd be in favor of renaming or removing
these constructs once we can make backwards-incompatible changes ;)

On Thu, Feb 18, 2016 at 8:31 AM, Ben Chambers <bc...@google.com.invalid>
wrote:

> Classes named "Bound" are used throughout the sdk to describe builders that
> are specified enough to be applied. It indicates that the required
> parameters have been bound. It is not related to whether the output
> PCollection is bounded or unbounded.
>
> On Thu, Feb 18, 2016, 7:42 AM bakey pan <ba...@gmail.com> wrote:
>
> > Hi,all:
> >     I notice that in in the PubSubIO class, there only exist one Bound
> > static class inherit from PTransform.
> >     But actually in the apply method of Bound,whether return a bounded or
> > unbounded PCollection is depend on the variables maxNumRecords and
> > maxReadTime.So why not name this class "MixBound" or else.
> >      I think that is a little bit confuse name it  "Bound" but actually
> it
> > can be unbouned data stream
> >
> > --
> >  Best Regards
> >    BakeyPan
> >
>

Re: Confusing about the bouded naming of PubsubIO

Posted by Ben Chambers <bc...@google.com.INVALID>.
Classes named "Bound" are used throughout the sdk to describe builders that
are specified enough to be applied. It indicates that the required
parameters have been bound. It is not related to whether the output
PCollection is bounded or unbounded.

On Thu, Feb 18, 2016, 7:42 AM bakey pan <ba...@gmail.com> wrote:

> Hi,all:
>     I notice that in in the PubSubIO class, there only exist one Bound
> static class inherit from PTransform.
>     But actually in the apply method of Bound,whether return a bounded or
> unbounded PCollection is depend on the variables maxNumRecords and
> maxReadTime.So why not name this class "MixBound" or else.
>      I think that is a little bit confuse name it  "Bound" but actually it
> can be unbouned data stream
>
> --
>  Best Regards
>    BakeyPan
>