You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@mesos.apache.org by "Benjamin Hindman (JIRA)" <ji...@apache.org> on 2015/07/06 21:50:06 UTC
[jira] [Updated] (MESOS-2800) Rename Option::get(const T& _t) to
getOrElse() and refactor the original function
[ https://issues.apache.org/jira/browse/MESOS-2800?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Benjamin Hindman updated MESOS-2800:
------------------------------------
Shepherd: Benjamin Hindman
Sprint: Mesosphere Sprint 14
Story Points: 3
> Rename Option<T>::get(const T& _t) to getOrElse() and refactor the original function
> ------------------------------------------------------------------------------------
>
> Key: MESOS-2800
> URL: https://issues.apache.org/jira/browse/MESOS-2800
> Project: Mesos
> Issue Type: Improvement
> Components: stout
> Reporter: Mark Wang
> Assignee: Mark Wang
> Priority: Minor
> Labels: newbie
>
> As suggested, if we want to change the name then we should refactor the original function as opposed to having 2 copies.
> If we did have 2 versions of the same function, would it make more sense to delegate one of them to the other.
> As of today, there is only one file need to be refactor: 3rdparty/libprocess/3rdparty/stout/include/stout/os/osx.hpp at line 151, 161
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)