You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@commons.apache.org by "木易什么来着 (Jira)" <ji...@apache.org> on 2019/11/18 07:53:00 UTC

[jira] [Updated] (COLLECTIONS-736) CollectionUtils containsAny Improvement

     [ https://issues.apache.org/jira/browse/COLLECTIONS-736?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

木易什么来着 updated COLLECTIONS-736:
-------------------------------
    Description: 
I think it's better to judge null in the code rather than let the user pass non null parameters.

 

For example, add such a piece of code:
{code:java}
//
if (isEmpty(coll1) || isEmpty(coll2)) {
    return false; 
}
{code}
It might be better in this way.

  was:
I think it's better to judge null in the code rather than let the user pass non null parameters.

 

For example, add such a piece of code:
{code:java}
//代码占位符
{code}
if (isEmpty(coll1) || isEmpty(coll2)) \{ return false; }

 

It might be better in this way.


> CollectionUtils containsAny Improvement
> ---------------------------------------
>
>                 Key: COLLECTIONS-736
>                 URL: https://issues.apache.org/jira/browse/COLLECTIONS-736
>             Project: Commons Collections
>          Issue Type: Improvement
>          Components: Collection
>    Affects Versions: 4.4
>            Reporter: 木易什么来着
>            Priority: Minor
>
> I think it's better to judge null in the code rather than let the user pass non null parameters.
>  
> For example, add such a piece of code:
> {code:java}
> //
> if (isEmpty(coll1) || isEmpty(coll2)) {
>     return false; 
> }
> {code}
> It might be better in this way.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)