You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@trafficserver.apache.org by "Leif Hedstrom (JIRA)" <ji...@apache.org> on 2013/08/23 17:27:52 UTC

[jira] [Updated] (TS-2143) Refactor and fix the alarms executable invocation and script

     [ https://issues.apache.org/jira/browse/TS-2143?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Leif Hedstrom updated TS-2143:
------------------------------

    Assignee:     (was: Leif Hedstrom)
     Summary: Refactor and fix the alarms executable invocation and script  (was: Remove alarm email address support (and config))

I reverted this. Surprisingly, people really want to configure the email address via records.config. I'd still recommend we eliminate proxy.config.alarm.admin.admin_user for v5.0, and pick a better name.
                
> Refactor and fix the alarms executable invocation and script
> ------------------------------------------------------------
>
>                 Key: TS-2143
>                 URL: https://issues.apache.org/jira/browse/TS-2143
>             Project: Traffic Server
>          Issue Type: Improvement
>          Components: Configuration, Core
>            Reporter: Leif Hedstrom
>             Fix For: 4.1.0
>
>
> E.g. proxy.config.alarm.admin.admin_user is only used for sending an email address to the alarm script. Instead of passing email address, I think we should pass the alarm_t (type) that generated the alarm.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira