You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ozone.apache.org by "ASF GitHub Bot (Jira)" <ji...@apache.org> on 2021/01/31 09:10:00 UTC

[jira] [Updated] (HDDS-4769) Simplify the insert operation of ContainerAttribute

     [ https://issues.apache.org/jira/browse/HDDS-4769?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

ASF GitHub Bot updated HDDS-4769:
---------------------------------
    Labels: pull-request-available  (was: )

> Simplify the insert operation of ContainerAttribute
> ---------------------------------------------------
>
>                 Key: HDDS-4769
>                 URL: https://issues.apache.org/jira/browse/HDDS-4769
>             Project: Hadoop Distributed Data Store
>          Issue Type: Improvement
>            Reporter: Janus Chow
>            Assignee: Janus Chow
>            Priority: Major
>              Labels: pull-request-available
>
> Currently when inserting a containerId to a ContainerAttribute, if the containerId is already in the ContainerAttribute, it will first remove the containerId and then add it again, but the value of containerId is not changed at all.
> The ticket is for simplifying the insert operation for better performance and readability.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@ozone.apache.org
For additional commands, e-mail: issues-help@ozone.apache.org