You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Xiaoyu Yao (JIRA)" <ji...@apache.org> on 2018/02/08 23:56:00 UTC

[jira] [Commented] (HDFS-13052) WebHDFS: Add support for snasphot diff

    [ https://issues.apache.org/jira/browse/HDFS-13052?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16357729#comment-16357729 ] 

Xiaoyu Yao commented on HDFS-13052:
-----------------------------------

Thanks [~ljain] for working on this. The patch looks good to me overall. Just have a few minor issues:

WebhdfsFileSystem.java
Line 1323: getSnapshotDiffReport should not increment the write op statistics.

SnapshotDiffReport.java
Line 196: I agree that getToSnapshot() can be a more accurate name. But let's keep the original getLaterSnapshotName() API as this is a public. Keeping it unchanged avoid potential backward compatibility issues.

JsonUtilClient.java
Line 706: debug output to System.err.println can be removed.




> WebHDFS: Add support for snasphot diff
> --------------------------------------
>
>                 Key: HDFS-13052
>                 URL: https://issues.apache.org/jira/browse/HDFS-13052
>             Project: Hadoop HDFS
>          Issue Type: Task
>            Reporter: Lokesh Jain
>            Assignee: Lokesh Jain
>            Priority: Major
>         Attachments: HDFS-13052.001.patch, HDFS-13052.002.patch, HDFS-13052.003.patch
>
>
> This Jira aims to implement snapshot diff operation for webHdfs filesystem.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org