You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Andrew Or (JIRA)" <ji...@apache.org> on 2015/06/10 20:33:00 UTC
[jira] [Created] (SPARK-8294) Break down large methods in YARN code
Andrew Or created SPARK-8294:
--------------------------------
Summary: Break down large methods in YARN code
Key: SPARK-8294
URL: https://issues.apache.org/jira/browse/SPARK-8294
Project: Spark
Issue Type: Sub-task
Components: YARN
Affects Versions: 1.4.0
Reporter: Andrew Or
What large methods am I talking about?
Client#prepareLocalResources ~ 170 lines
ExecutorRunnable#prepareCommand ~ 100 lines
Client#setupLaunchEnv ~ 100 lines
... many others that hover around 80 - 90 lines
There are several things wrong with this. First, it's difficult to follow / review the code. Second, it's difficult to test it at a fine-granularity. In the past we as a community has been reluctant to add new regression tests for YARN changes. This stems from the fact that it is difficult to write tests, and the cost is that we can't really ensure the correctness of the code easily.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)
---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org