You are viewing a plain text version of this content. The canonical link for it is here.
Posted to reviews@mesos.apache.org by Anand Mazumdar <an...@apache.org> on 2017/02/03 04:45:45 UTC

Review Request 56267: Made `kill` not use pipelining in the default executor.

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/56267/
-----------------------------------------------------------

Review request for mesos and Vinod Kone.


Bugs: mesos-6296
    https://issues.apache.org/jira/browse/mesos-6296


Repository: mesos


Description
-------

The previous code used to pipeline all the `KILL_NESTED_CONTAINER`
calls on the same connection. This change removes this and invokes
`post` for each child container. This simplifies the code and
makes it more readable.


Diffs
-----

  src/launcher/default_executor.cpp 97eee05cac8cb1f62d43e2aecc08a8e54e49eac3 

Diff: https://reviews.apache.org/r/56267/diff/


Testing
-------

make check


Thanks,

Anand Mazumdar


Re: Review Request 56267: Made `kill` not use pipelining in the default executor.

Posted by Vinod Kone <vi...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/56267/#review164177
-----------------------------------------------------------


Ship it!




Ship It!

- Vinod Kone


On Feb. 3, 2017, 4:45 a.m., Anand Mazumdar wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/56267/
> -----------------------------------------------------------
> 
> (Updated Feb. 3, 2017, 4:45 a.m.)
> 
> 
> Review request for mesos and Vinod Kone.
> 
> 
> Bugs: mesos-6296
>     https://issues.apache.org/jira/browse/mesos-6296
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> The previous code used to pipeline all the `KILL_NESTED_CONTAINER`
> calls on the same connection. This change removes this and invokes
> `post` for each child container. This simplifies the code and
> makes it more readable.
> 
> 
> Diffs
> -----
> 
>   src/launcher/default_executor.cpp 97eee05cac8cb1f62d43e2aecc08a8e54e49eac3 
> 
> Diff: https://reviews.apache.org/r/56267/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Anand Mazumdar
> 
>